Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225911

Summary: Merge Review: ipvsadm
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Parag AN(पराग) <panemade>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: kupcevic, matthias
Target Milestone: ---Flags: panemade: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-18 14:29:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-31 19:07:04 UTC
Fedora Merge Review: ipvsadm

http://cvs.fedora.redhat.com/viewcvs/devel/ipvsadm/
Initial Owner: kupcevic@redhat.com

Comment 1 Parag AN(पराग) 2007-08-31 05:25:22 UTC
Correct Buildroot.
Use macros. check http://fedoraproject.org/wiki/Packaging/RPMMacros
Though dist tag is not mandatory but its good to have it in SPEC.
update SPEC for further review.

Comment 2 Matthias Saou 2007-11-27 13:09:21 UTC
Update what? I won't add any dist tag, because the package pretty much never
changes. Could you detail "Use macros.", please?

Comment 3 Parag AN(पराग) 2007-11-27 14:03:46 UTC
(In reply to comment #2)
> Update what? I won't add any dist tag, because the package pretty much never
> changes. Could you detail "Use macros.", please?
Fine.
I think I have given link where to look for using macros in SPEC.
Review Guidelines said
- MUST: Each package must consistently use macros, as described in the macros
section of Packaging Guidelines. 

And I only asked you to change
/etc/rc.d/init.d under %flies as given
http://fedoraproject.org/wiki/Packaging/RPMMacros on as
/etc/rc.d/init.d => %{_initrddir}


Comment 4 Matthias Saou 2007-11-27 16:25:29 UTC
No, I won't use that macro. It's wrong, plain wrong. If it was called _initddir
or even _initdir, why not.

Comment 5 Parag AN(पराग) 2007-11-27 16:56:39 UTC
Then should we ask Fedora Packaging Committee to remove that usage if its wrong
way to use that macro?

Comment 6 Parag AN(पराग) 2008-01-18 14:29:24 UTC
otherwise else spec looks fine.

APPROVED.