Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225665

Summary: Dragging text in pycrust makes entire GUI unresponsive
Product: [Fedora] Fedora Reporter: Brad Smith <brads>
Component: compat-wxPythonGTK2Assignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-02 21:23:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Brad Smith 2007-01-31 17:53:51 UTC
Description of problem:
When text is highlighted+dragged in pycrust, which comes with
compat-wxPythonGTK2, the mouse pointer changes to the "pointer with files" image
to indicate that text is being dragged. However, when the mouse is released,
text is not pasted, the mouse pointer does not change back and the entire gui
becomes unresponsive. By "the entire gui", I do not mean just pycrust, but all
of Gnome, inclduding keyboard commands like alt+tab (alt+down, which I have
mapped to mimize, does work for some reason). I have to go to a virtual terminal
and kill pycrust to get Gnome back. 

I don't know if it's a problem with pycrust or with WXwin in general

Version-Release number of selected component (if applicable):
2.4.2.4-12.fc6

How reproducible:
Every time. It wouldn't be a such a huge problem if I didn't keep doing it
accidentally. =:(

Steps to Reproduce:
1. Highlight text in pycrust
2. Drag text elsewhere in pycrust
  
Actual results:
Mouse pointer does not rever to default, GUI becomes unresponsive

Expected results:
Text is pasted, mouse pointer reverts to default

Comment 1 Tom "spot" Callaway 2008-01-02 21:23:44 UTC
Tested this in rawhide (sorry it took so long to get to this) and it seems to be
resolved. Closing as NOTABUG.