Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225428

Summary: Paravirtualized xen guest hangs when guest is shutdown - Guest domain does not terminate
Product: Red Hat Enterprise Linux 5 Reporter: Joseph Szczypek <joseph.szczypek>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0   
Target Milestone: ---   
Target Release: ---   
Hardware: ia64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-30 19:32:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joseph Szczypek 2007-01-30 16:13:55 UTC
Description of problem:
When shutting down a paravirtualized xen guest, the guest hangs (the domain does
not terminate.  I've experienced this problem at the point where auditd is
shutting down.   I've disabled auditd using chkconfig and then experience the
problem at the point where 'Halting system' is displayed.  The domain doesn't
terminate.

Version-Release number of selected component (if applicable):
2.6.18-1.3002.el5xen (rcs7)

How reproducible:
Occurs every time I shut the guest down.

Steps to Reproduce:
1. "shutdown -h now" in the guest, or
2. "xm shutdown 'guest_id'" in dom0
  
Actual results:
Guest domain does not terminate.

Expected results:
Guest domain should terminate.

Additional info:
Paravirtualized guest has 2GB of memory, 2 vcpus, and is installed to a physical
(SCSI) disk.  Guest and Dom0 are installed with the same version of the OS.

Comment 1 Markus Armbruster 2007-01-30 19:32:51 UTC

*** This bug has been marked as a duplicate of 221626 ***