Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225294

Summary: Merge Review: authd
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Gwyn Ciesla <gwync>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jsafrane, rrakus
Target Milestone: ---Keywords: Reopened
Target Release: ---Flags: gwync: fedora-review+
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-06 15:47:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-29 21:07:55 UTC
Fedora Merge Review: authd

http://cvs.fedora.redhat.com/viewcvs/devel/authd/

Comment 1 Gwyn Ciesla 2008-02-05 20:12:49 UTC
rpmlint on srpm:

authd.src:7: W: unversioned-explicit-obsoletes pidentd
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

authd.src:18: W: prereq-use xinetd
The use of PreReq is deprecated. In the majority of cases, a plain Requires
is enough and the right thing to do. Sometimes Requires(pre), Requires(post),
Requires(preun) and/or Requires(postun) can also be used instead of PreReq.

authd.src: W: no-url-tag
The URL tag is missing.


These need fixing.


rpmlint on rpms:

authd.i386: E: non-readable /etc/ident.key 0640
The file can't be read by everybody. If this is expected (for security
reasons), contact your rpmlint distributor to get it added to the list of
exceptions for your distro (or add it to your local configuration if you
installed rpmlint from the source tarball).

authd.i386: E: zero-length /etc/ident.key

authd.i386: W: conffile-without-noreplace-flag /etc/ident.key
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


These are OK.

authd.i386: W: dangerous-command-in-%post chown

Fix if possible, might want to use the full path to chown.

In addition to needing a URL tag, the Source tag needs a url pointing to the
upstream tarball.  If Fedora or RH are upstream, get a space on hosted.

License tag should be GPLv2+.

Error in rawhide mock build:

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.30946
+ umask 022
+ cd /builddir/build/BUILD
+ cd authd-1.4.3
+ LANG=C
+ export LANG
+ unset DISPLAY
+ make prefix=/usr
gcc -std=gnu99 -Wall -W -DNDEBUG -g -O -lcrypto -o in.authd authd.c
authd.c: In function 'created_pton_hex':
authd.c:198: error: 'struct in6_addr' has no member named 'in6_u'
authd.c:202: error: 'struct in6_addr' has no member named 'in6_u'
authd.c: In function 'initialize_crypto':
authd.c:784: warning: pointer targets in passing argument 4 of 'EVP_BytesToKey'
differ in signedness
make: *** [in.authd] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.30946 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.30946 (%build)
EXCEPTION: Command failed. See logs for output.
 # bash -l -c 'rpmbuild -bb --target i386 --nodeps
//builddir/build/SPECS/authd.spec'
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.5/site-packages/mock/util.py", line 286, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" %
(command,), ret)
Error: Command failed. See logs for output.
 # bash -l -c 'rpmbuild -bb --target i386 --nodeps
//builddir/build/SPECS/authd.spec'
LEAVE do --> EXCEPTION RAISED


Other than that, looks good, no other blockers.

Comment 2 Gwyn Ciesla 2008-02-06 12:32:58 UTC
Adding authd maintainer listed in pkgdb to cc.

Comment 3 Jan Safranek 2008-02-13 10:02:50 UTC
(In reply to comment #1)
> rpmlint on srpm:
> 
> authd.src:7: W: unversioned-explicit-obsoletes pidentd
Fixed

> authd.src:18: W: prereq-use xinetd
Fixed

> authd.src: W: no-url-tag
See below

> authd.i386: E: non-readable /etc/ident.key 0640
That's an intention, it's secret password.

> authd.i386: E: zero-length /etc/ident.key
That's an intention, it's zero-length secret password.

> authd.i386: W: conffile-without-noreplace-flag /etc/ident.key
That's an intention, do not overwrite the password.
> These are OK.


> authd.i386: W: dangerous-command-in-%post chown
> Fix if possible, might want to use the full path to chown.
Chown is needed, and there *is* full path to /bin/chown.

> In addition to needing a URL tag, the Source tag needs a url pointing to the
> upstream tarball.  If Fedora or RH are upstream, get a space on hosted.
I did not find any upstream of authd, did I miss something? If there is not any,
I'll go to fedorahosted.org

> License tag should be GPLv2+.
Fixed

> Error in rawhide mock build:
Fixed

> Other than that, looks good, no other blockers.
Thanks for the review!

After the fixes (authd-1.4.3-14.rpm), rpmlint complains about:
authd.i386: E: non-readable /etc/ident.key 0640
authd.i386: E: zero-length /etc/ident.key
authd.i386: W: no-url-tag
authd.i386: W: conffile-without-noreplace-flag /etc/ident.key
authd.i386: W: dangerous-command-in-%post chown
authd.src: W: no-url-tag
authd-debuginfo.i386: W: no-url-tag

All these errors except url are described above. 

Comment 4 Gwyn Ciesla 2008-02-13 13:23:22 UTC
You're welcome!

> authd.i386: W: dangerous-command-in-%post chown
> Fix if possible, might want to use the full path to chown.
Chown is needed, and there *is* full path to /bin/chown.

Sorry, I meant full path to chmod, line 59.

Otherwise, yes, I'd get a spot on hosted and update with the results.

Comment 5 Jan Safranek 2008-02-27 13:43:59 UTC
authd got a new maintaner: rrakus@redhat.com.

Roman, please try to find upstream and if it does not exist, please create your
own on fedorahosted.org. You can ask maintainers of other distributions to
cooperate and unify your patches. Or kick authd out of Fedora, if nobody uses it :)

Comment 6 Roman Rakus 2008-03-05 15:25:10 UTC
Upstream not exists.
Created on fedorahosted.org: https://fedorahosted.org/authd/
Also added dist tag.

Comment 7 Gwyn Ciesla 2008-03-05 15:34:04 UTC
Sorry, can't close until approved.

Looks goos, but Source0 needs to include URL to tarball, i.e.
https://fedorahosted.org/authd/attachment/wiki/WikiStart/authd-1.4.3.tar.gz

Comment 8 Roman Rakus 2008-03-06 09:20:09 UTC
I'm sorry for my mistake.
Source0 fixed. Looks like to be good now. Can you please check it once again?
Thank you.

Comment 9 Gwyn Ciesla 2008-03-06 12:31:10 UTC
Looks perfectly cromulent now.  Oddly, the md5sums between the Source0: tarball
and the one from the koji SRPM don't match.  gunzip fails and file says it's html.

Looks like
https://fedorahosted.org/authd/attachment/wiki/WikiStart/authd-1.4.3.tar.gz?format=raw
will work, but will add the ?format=raw to the end of the filename.

THEN the md5sum matches.  So it looks like the tag needs changing one more time,
with a note about the filename in the spec.  

Sorry. :)

Comment 10 Roman Rakus 2008-03-06 15:00:42 UTC
Done some changes. Sources uploaded to svn - http://svn.fedorahosted.org/svn/authd/
Changed homepage - https://fedorahosted.org/authd/
Changed spec file Source0.
Now it must be perfect! :)

Can you take a look at it, please? :)

Comment 11 Gwyn Ciesla 2008-03-06 15:47:23 UTC
Beauteous. :)  Thank you!

APPROVED.