Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225247

Summary: Merge Review: anacron
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Marcela Mašláňová <mmaslano>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jspaleta, mmaslano, redhat-bugzilla
Target Milestone: ---Flags: jspaleta: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-20 07:51:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
spec file diff of doom. This has all the changes that need to be made to pass the merge review none

Description Nobody's working on this, feel free to take it 2007-01-29 21:01:00 UTC
Fedora Merge Review: anacron

http://cvs.fedora.redhat.com/viewcvs/devel/anacron/

Comment 1 Jef Spaleta 2007-02-03 17:03:53 UTC
Summary: Minor items need fixing before I can sign off on the review. See the
attached spec file diff which includes the needed changes. Once the changes get
into the cvs tree, ping this report so I can confirm and approve.

anacron
GOOD
+ rpmlint... see the notes at the end. I've rolled in changes into the spec from
the rpmlint log
+ packagename is fine
+ specfile name
+ license check 
  GPL , matches source license, and COPYING file included in %doc
+ spec is english-ish
+ md5sum check of sources
9fdfc50f5741643332722a9145146278  anacron_2.3.orig.tar.gz from srpm
9fdfc50f5741643332722a9145146278  anacron_2.3.orig.tar.gz from upstream url 
+mock build  as done by matt
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/anacron-2.3-45.fc7.src.rpm/result/

+ no buildrequires....
+ no shared libs
+ not designed to be relocatable
+ no duplicates in the files section
+ file permissions look okay to me
+ no headers or static libs
+ docs section looks fine
+ no devel subpackage
+ no gui apps
+ no obvious duplicate file/directory ownership

BAD
- need to add requires on initscripts do to file in /etc/rc.d/init.d/
  Ref ReviewGuidelines
  MUST: A package must own all directories that it creates. 
  If it does not create a directory that it uses, then it should require 
  a package which does create that directory.

- SRC location in spec not connecting
  this one works
http://ftp.debian.org/debian/pool/main/a/anacron/anacron_2.3.orig.tar.gz

- NEEDSFIX Prereq: /sbin/chkconfig
  replace with 2 lines for scriptlet operation  
  Requires(post): /sbin/chkconfig
  Requires(preun): /sbin/chkconfig
  
- NEEDSFIX you also need 
  Requires(postun): /sbin/service 
  Requires(preun): /sbin/service

- NEEDSFIX clean the buildroot correctly





rpmlint run from matt/dell:

rpmlint on ./anacron-2.3-45.fc7.i386.rpm
W: anacron summary-ended-with-dot A cron-like program that can run jobs lost
during downtime.
...fixed in my spec diff
W: anacron no-url-tag
...Not necessary, but since debian is the upstream src for this perhaps
URL: http://packages.debian.org/stable/source/anacron
ive added this in my spec diff

W: anacron conffile-without-noreplace-flag /etc/anacrontab
W: anacron conffile-without-noreplace-flag /etc/cron.daily/0anacron
W: anacron conffile-without-noreplace-flag /etc/cron.monthly/0anacron
W: anacron conffile-without-noreplace-flag /etc/cron.weekly/0anacron

...These should really be marked as noreplace.  I think you definitely want
rpm to respect any local changes to thise files.
Changed in my spec diff.

W: anacron conffile-without-noreplace-flag /etc/rc.d/init.d/anacron
...This one probably shouldn't be noreplace.


E: anacron executable-marked-as-config-file /etc/cron.weekly/0anacron
E: anacron executable-marked-as-config-file /etc/rc.d/init.d/anacron
E: anacron executable-marked-as-config-file /etc/cron.daily/0anacron
E: anacron executable-marked-as-config-file /etc/cron.monthly/0anacron
...rpmlint is being paranoid.  The cron scripts are typically executables
which need to be local admin configurable.

W: anacron service-default-enabled /etc/rc.d/init.d/anacron
...not a problem.. if you really really mean to have anacron on by default.

W: anacron incoherent-subsys /etc/rc.d/init.d/anacron $prog
...Dude i have no idea what this means

W: anacron no-reload-entry /etc/rc.d/init.d/anacron
...not horrible important.

rpmlint on ./anacron-2.3-45.fc7.src.rpm
W: anacron summary-ended-with-dot A cron-like program that can run jobs lost
during downtime.
W: anacron no-url-tag
W: anacron strange-permission anacron.init 0755
W: anacron prereq-use /sbin/chkconfig
E: anacron no-cleaning-of-buildroot %install
...that's not good...fixed in my spec diff

W: anacron mixed-use-of-spaces-and-tabs (spaces: line 83, tab: line 92)
...no biggie
W: anacron patch-not-applied Patch7: anacron-2.3-pie.patch
W: anacron patch-not-applied Patch8: anacron-2.3-memoryleak.patch
...no biggie

rpmlint on ./anacron-debuginfo-2.3-45.fc7.i386.rpm
W: anacron-debuginfo no-url-tag


Comment 2 Jef Spaleta 2007-02-03 17:05:38 UTC
Created attachment 147276 [details]
spec file diff of doom. This has all the changes that need to be made to pass the merge review

This has all the changes that need to be made to pass the merge review

Comment 3 Marcela Mašláňová 2007-02-06 14:39:23 UTC
Thanks for review. 
src.rpm
I change some other things and my rpmlint says only:
E: anacron executable-marked-as-config-file /etc/rc.d/init.d/anacron
W: anacron service-default-enabled /etc/rc.d/init.d/anacron
W: anacron incoherent-subsys /etc/rc.d/init.d/anacron $prog
W: anacron no-reload-entry /etc/rc.d/init.d/anacron
rpm
W: anacron strange-permission anacron.init 0755

Comment 4 Jef Spaleta 2007-02-10 22:50:10 UTC
okay the new build looks good to me. All the blockers are fixed and additional
warnings from rpmlint were fixed as well. New srpm builds under mock locally
under x86.

APPROVED

Comment 5 Warren Togami 2007-02-12 21:20:31 UTC
Unsetting fedora-cvs, as Core Merge Reviews are already in CVS, and will be part
of the mass move when we are ready to merge the distro later.