Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225183

Summary: System properties doesn't support unicode characters
Product: Red Hat Satellite 5 Reporter: Pete Vetere <pvetere>
Component: ServerAssignee: Miroslav Suchý <msuchy>
Status: CLOSED CURRENTRELEASE QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 500CC: cperry, msuchy
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-21 11:37:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pete Vetere 2007-01-29 17:37:34 UTC
Description of problem:

The system properties page incorrectly interprets unicode characters.

Version-Release number of selected component (if applicable):

5.0

How reproducible:

Always

Steps to Reproduce:
1. Create a system
2. In the system properties for that system, set City to something like 'éà'
3. Click Update Properties
4. Notice that the characters you entered are incorrectly displayed in the
System details screen.
  
Actual results:

Unicode characters incorrectly displayed

Expected results:

Unicode characters are correctly displayed

Comment 3 Miroslav Suchý 2011-01-21 11:37:05 UTC
Works correctly in RHN Satellite 5.4