Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 224907

Summary: [RFE] rarpd daemon startup options not configurable as packaged
Product: Red Hat Enterprise Linux 5 Reporter: Jon Stanley <jon.stanley>
Component: rarpdAssignee: Jiri Moskovcak <jmoskovc>
Status: CLOSED NOTABUG QA Contact: BaseOS QE <qe-baseos-auto>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: dfediuck, dhunter, dmair, jeder, tao
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-09 14:26:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jon Stanley 2007-01-27 05:53:44 UTC
+++ This bug was initially created as a clone of Bug #218998 +++

Description of problem:
By default rarpd will not answer a request if a boot image for the requesting
client is not found in the /tftpboot. I use rarpd only to answer requests
for Sun T3s and 3510FC devices that have no use for a boot image.

To get around this one must pass a -e to the daemon.

       -e     Skip the check for bootable image in the TFTP boot directory. If
              not present, then even if the Ethernet address is present in the
              ethers  database but the bootable image for the resolved IP does
              not exist, rarpd will not respond to the request.


It would be nice if you could modify the init script as follows:

[root@noc init.d]# diff -u rarpd.orig rarpd
--- rarpd.orig 2006-02-12 01:06:26.000000000 -0800
+++ rarpd 2006-11-30 17:36:08.000000000 -0800
@@ -11,6 +11,10 @@
# Source function library.
. /etc/init.d/functions

+if [ -f /etc/sysconfig/rarpd ]; then
+ . /etc/sysconfig/rarpd
+fi
+
test -x /usr/sbin/rarpd -a -f /etc/ethers || exit 0

RETVAL=0
@@ -20,7 +24,7 @@
# Check if rarpd is already running
if [ ! -f /var/lock/subsys/rarpd ]; then
echo -n $"Starting $prog: "
- daemon /usr/sbin/rarpd
+ daemon /usr/sbin/rarpd $OPTIONS $INTERFACE
RETVAL=$?
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/rarpd
echo

[root@noc init.d]# cat /etc/sysconfig/rarpd
OPTIONS="-e -v"
INTERFACE="eth1"

Version-Release number of selected component (if applicable):
rarpd-ss981107-18.40.2

How reproducible:
Always

Steps to Reproduce:
1. service start rarpd
  
Actual results:
No means to configure options.

Expected results:
Tweakage of sysconfig file. Options are:
 rarpd [ -dveaA ] [ -b tftpdir ] [ interface]

Additional info:

Comment 1 RHEL Product and Program Management 2008-02-01 19:10:13 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 2 Jon Stanley 2008-02-01 19:35:54 UTC
I'm not sure what the problem is here.  I'll open a support case for this, but
there's a patch here - the Fedora version of this bug is already long fixed, and
this is a minimal impact change - it simply adds functionality that should
already be there.

If someone could appeal the RHEL 4.7 decision, and propose for RHEL 4.8, I would
be eternally grateful.

Comment 3 RHEL Product and Program Management 2008-10-31 16:50:37 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 7 RHEL Product and Program Management 2009-03-26 17:21:36 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".