Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 224681

Summary: "parted --script <dev> mklabel msdos" no longer works
Product: Red Hat Enterprise Linux 5 Reporter: Nick Dokos <nicholas.dokos>
Component: partedAssignee: David Cantrell <dcantrell>
Status: CLOSED NEXTRELEASE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: dchapman
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-09-13 21:19:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nick Dokos 2007-01-26 23:54:52 UTC
Description of problem:
I use "parted --script <dev> mklabel msdos" and also
"parted --script <dev> mkpart 0 -1" in scripts,
but they have recently started failing - I think since RHEL5 rcs6
but it may go back to earlier snapshots; I believe it worked in
the beta2 from last October.

Version-Release number of selected component (if applicable):
parted-1.8.1-4.el5

How reproducible:
Always

Steps to Reproduce:
1.Go into parted and change the label of some device to e.g. "loop", then quit.
2.At a shell prompt, say: parted --script <dev> mklabel msdos
3.
  
Actual results:
# parted --script /dev/sdb mklabel msdos
Warning: The existing disk label on /dev/sdb will be destroyed and all data on
this disk will be lost. Do you want to continue?
#

and the label does *not* change.

Expected results:
I expect the label of the disk to be set to "msdos". In fact, I expect
no warning since the --script option is documented in the man page as
follows:
 
       -s, --script
              never prompt the user.


Additional info:

Comment 1 David Cantrell 2007-09-13 21:19:50 UTC
Checked latest RHEL 5.1 test builds and the --script option is now working as
expected (i.e., it won't prompt you).

I used your two test commands:
parted --script <dev> mklabel msdos
parted --script <dev> mkpart 0 -1

The mklabel one works fine, but the mkpart one is actually invalid.  It lacks
the partition type.  Also, you can't specify -1 as the ending point.  So I used:

parted --script <dev> mkpart primary 0 1

And that worked.

Closing as nextrelease since this will be fixed in RHEL 5.1.

Comment 2 Nick Dokos 2007-09-14 00:27:31 UTC
How do you specify that the partition is to take up the whole disk?
That's what I used the -1 for: if I cannot use that, is there
another way?

Also, do you have a version number for the package that I should
get to try it out?

Thanks!