Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 224644

Summary: Autotools build ends up building twice sometimes or cleaning first
Product: [Fedora] Fedora Reporter: Jeff Johnston <jjohnstn>
Component: eclipse-cdtAssignee: Jeff Johnston <jjohnstn>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-26 21:15:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Johnston 2007-01-26 20:43:44 UTC
This bug entails a couple of build problems with Autotools.  Sometimes, the
build will run and then start again.  Other times, a build will be issued and
Autotools will do a make clean all which causes unnecessary churn.

Comment 1 Jeff Johnston 2007-01-26 21:15:26 UTC
A number of problems existed.  The ManagedBuild project calls clean() when doing
a full build and this attempts to remove the build directory.  Thankfully, the
ManagedMake project assumes the build directory is named the same as the
configuration which is rarely true.  The clean call is unnecessary and has been
disabled in this circumstance.  Fixes have been made so a UI clean will actually
invoke make clean rather than attempt to delete the directory.