Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 224580

Summary: Error in post install script
Product: [Fedora] Fedora Reporter: Phil Knirsch <pknirsch>
Component: lvm2-clusterAssignee: Alasdair Kergon <agk>
Status: CLOSED CURRENTRELEASE QA Contact: Corey Marthaler <cmarthal>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: agk, ccaulfie, dwysocha, jbrassow, mbroz, prockai, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: lvm2-2.02.12-2.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-26 16:09:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Phil Knirsch 2007-01-26 15:23:00 UTC
During an automated install/deinstall check the following error has happened:

ERROR: Output running post install script for package
lvm2-cluster-0:2.02.11-4.fc7.i386
/usr/lib/liblvm2clusterlock.so does not exist, did you do a "make install" ?

Please make sure that /usr/lib/liblvm2clusterlock.so is installed and packaged
with lvm2-cluser or provided by one of the other lvm2 packages.

Comment 1 Alasdair Kergon 2007-01-26 15:49:54 UTC
I'm confused why your report relates to an old package: the current devel
version is 2.02.20-1 and the package you mention was superceded in October.

liblvm2clusterlock.so is an old file no longer supplied.

We need to see if this is still a problem in the current package, and if it is,
remove that check and error message.


Comment 2 Alasdair Kergon 2007-01-26 16:09:31 UTC
At first sight the current package looks fine:

-        if [ ! -f "$LOCKINGLIBDIR/$LOCKINGLIB" ]
+        if [ -n "$LOCKINGLIB" ] && [ ! -f "$LOCKINGLIBDIR/$LOCKINGLIB" ]

should avoid that message appearing.

Comment 3 Karsten Hopp 2007-01-26 16:14:02 UTC
I think the old package was checked because download.fedora.redhat.com and its
mirrors have two lvm2-cluster packages, lvm2-cluster-2.02.11-4.fc7 and 2.02.19-2
This bug has been fixed in the meantime if you didn't get another report for the
newer package

Comment 4 Alasdair Kergon 2007-01-26 16:59:14 UTC
Aha!  2.02.11-4.fc7 was the last version of lvm2-cluster built independently,
before it was merged into the lvm2.spec file.

More fallout from this?  Does something further need updating in one of the
systems somewhere to stop the lvm2-cluster package from being distributed?