Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 224391

Summary: pirut exception while Retrieving Software Information
Product: [Fedora] Fedora Reporter: Ned Forrester <nforrester>
Component: pirutAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-25 17:16:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
pirut dump output from exception none

Description Ned Forrester 2007-01-25 15:23:28 UTC
Description of problem:

On opening add/remove programs (pirut) or software updater (pup) application
crashes during the "retrieving software information" phase.

Version-Release number of selected component (if applicable):

Used to work:
kernel-2.6.18-1.2798.fc6
kernel-2.6.19-1.2895.fc6
kernel-devel-2.6.19-1.2895.fc6
kernel-headers-2.6.19-1.2895.fc6
pirut-1.2.8-1.fc6

Broke after intalling/using:
kmod-madwifi-0.9.2.1-2.2.6.19_1.2895.fc6
madwifi-0.9.2.1-1.lvn6
madwifi-devel-0.9.2.1-1.lvn6
wpa_supplicant-0.4.9-1.fc6
wpa_supplicant-gui-0.4.9-1.fc6
vpnc-0.3.3.tar.gz

How reproducible:

Used to work fine, now every time.  

Steps to Reproduce:
1. Start application (pirut or pup)
2.
3.
  
Actual results:

See attached dump file.

Expected results:

Should not generate an excpetion.

Additional info:

The applications worked yesterday with the same kernel but no longer work
after having worked on installing wifi and vpn.  wpa_supplicant was installed
previously, but had not been configured, madwifi and vpn are new.  Other
internet applications continue to work, so this is not an global network
problem.  

Any pointers regarding what to test next would be appreciated.

Comment 1 Ned Forrester 2007-01-25 15:23:29 UTC
Created attachment 146555 [details]
pirut dump output from exception

Comment 2 Jacek Piskozub 2007-01-25 15:32:28 UTC
This is another dupe of bug 224292

Comment 3 Michael Schwendt 2007-01-25 17:16:21 UTC

*** This bug has been marked as a duplicate of 224292 ***