Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 224085

Summary: kernel-2.6.19-1.2895.fc6 errors in compile
Product: [Fedora] Fedora Reporter: Dave Feldbauer <dfeldbauer1>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-24 08:46:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dave Feldbauer 2007-01-24 00:14:48 UTC
Description of problem:after install kernel update 2.6.19-1.2895.fc6 (updating
from 2.6.18-1.2869.fc6) I tried to remake network drivers for realtek rtl8187l
usb wireless card.  I have compiled these drivers in the older kernel and they
compiled and worked.  Now on compile i get this error 

/r8187_core.c:2421: error: ‘struct net_device’ has no member named
‘get_wireless_stats’
when trying to compile the drivers



Version-Release number of selected component (if applicable):

kernel-2.6.19-1.2895.fc6 
i686
How reproducible:

Every time

Steps to Reproduce:
1.compile drivers from Realtek rtl8187_linux_26.1010.zip
2.
3.
  
Actual results:

compiling exits with errors

/r8187_core.c:2421: error: ‘struct net_device’ has no member named
‘get_wireless_stats’
when trying to compile the drivers
Expected results:
drivers should compile

Additional info:

please contact for any additional logs or info

Comment 1 Jakub Jelinek 2007-01-24 08:46:33 UTC
That doesn't sound like a gcc bug, simply you downloaded some outdated kernel
module sources that is incompatible with recent changes in the kernel.