Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2233

Summary: xntp spec file does not create a file
Product: [Retired] Red Hat Linux Reporter: R P Herrold <herrold>
Component: xntp3Assignee: David Lawrence <dkl>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 5.2CC: taylor
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-15 19:21:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description R P Herrold 1999-04-17 13:27:28 UTC
/root]# rpm -V xntp3
missing    /etc/ntp/step-tickers

... the file is 'manifested' and appears to be a 'config'
class file -- although not so defiled in the config file.

it needs to be -touched' to create it, and highlighted as a
'config' class file.

Comment 1 Jeff Johnson 1999-04-17 15:40:59 UTC
The file /etc/ntp/step-tickers contains the names of reference
hosts that can be used by /etc/rc.d/init.d/xntpd to initially set the
system clock. The file is already marked
	%ghost %config(missingok)

Comment 2 R P Herrold 1999-04-17 20:45:59 UTC
... and how does that fix that fact that rpm -V reports.  This implies
a problem [under that principal that a proper unix program runs
silently if there is no problem], even if it IS to std-out?

Do you want me to transfer this to RPM as initially suggested?

------------
[root@swampfox autorpm]# rpm -V xntp3
missing    /etc/ntp/step-tickers
[root@swampfox autorpm]# rpm -V xntp3 > /dev/null
[root@swampfox autorpm]# rpm -V xntp3 2> /dev/null
missing    /etc/ntp/step-tickers
[root@swampfox autorpm]#

Comment 3 Jeff Johnson 1999-05-15 19:21:59 UTC
This "bug" revolves around the interpretation of the word missing
and how that should be implemented in rpm and has nothing to do with
xntp3. There is already a best effort to package xntp3 to take into
account that the file is a configuration file that is used by the
package but is not part of the package.

Comment 4 Jeff Johnson 1999-07-08 22:36:59 UTC
*** Bug 3950 has been marked as a duplicate of this bug. ***

It seems that the file /etc/ntp/step-tickers is missing from
the rpm package.  I verified this:
rpm -Vp xntp3-5.93-12
missing    /etc/ntp/step-tickers

The result was the same for the file from the CD and one of
the download mirrors.

Wally Taylor