Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 215495

Summary: gnome session deamon unable to determine the address of the message bus on start
Product: [Fedora] Fedora Reporter: Vitaliy S <yilativs>
Component: gnome-sessionAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED WONTFIX QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-18 18:41:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vitaliy S 2006-11-14 12:16:57 UTC
Description of problem:
When gnome session starts a window pop ups with error message:
There was an error starting the GNOME Settings Daemon.
Some things, such as themes, sounds, or background settings may not work correctly.
The last error message was:
Unable to determine the address of the message bus (try 'man dbus-launch' and
'man dbus-daemon' for help)
GNOME will still try to restart the Settings Daemon next time you log in.

=========================
log details:
 the authentication protocols specified are supported and host-based
authentication failed.
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/2502
write_all write failure:: Broken pipe
Window manager warning: Log level 32: could not find XKB extension.
Gnome-Message: gnome_execute_async_with_env_fds: returning -1
libnotify-Message: Unable to get session bus: Unable to determine the address of
the message bus (try 'man dbus-launch' and 'man dbus-daemon' for help)

Version-Release number of selected component (if applicable):
gnome-session-2.16.0-3.fc6
dbus-0.93-3.fc6

How reproducible:
execute 
/usr/bin/gnome-session

Comment 1 Vitaliy S 2006-11-20 12:29:18 UTC
I found a solution people have same problem here
http://gnomesupport.org/forums/viewtopic.php?t=11865

download
dbus-x11-0.93-3.fc6
dbus-glib-0.70-4
dbus-0.93-3.fc6 
and rpm -Uvh dbus-* --force

The solution provided doesn't work for me
I still have same error message.

Comment 2 Anatoly Pugachev 2007-03-12 07:46:23 UTC
was having same error, fixed by installing dbus-x11 rpm package. you shouldn't 
use rpm --force to install packages, since it doesn't track package depencies. 
instead, remove that 3 packages you've installed and install them with yum -y 
install dbus-x11. hope that helps.

Comment 3 Ray Strode [halfline] 2008-03-18 18:41:31 UTC
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)