Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2069

Summary: Problem with F1..F4 and xterm vs. nxterm / termcap and terminfo
Product: [Retired] Red Hat Linux Reporter: sdh4
Component: termcapAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-04-09 15:16:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description sdh4 1999-04-08 21:25:48 UTC
The xterm and nxterm programs under at least RH 5.1 and 5.2
use the SAME termcap entries but exhibit DIFFERENT
characteristics. To demonstrate, open an xterm and an
nxterm, and in each type 'cat >/dev/null' and then
press F1 through F8
then ctrl-c and do a 'printenv TERM'. The net result is that
any text-based program which uses function keys will fail
depending upon which type of xterm the end user is using. An
obvious solution is to have the nxterm use the 'nxterm'
terminal type, except this won't work properly because there
is no /etc/termcap entry for nxterm (there IS a terminfo
entry).
So the problems are:
  #1: xterm and nxterm behave differently but claim to be
the same
  #2: the terminfo database is inconsistent with the termcap
database

(Note: Modern xterm implementations such as Solaris seem to
be using the nxterm function key method. For maximum
interoperability with remote-logins it is best to at least
try to use the same conventions as everyone else)

Comment 1 Preston Brown 1999-04-09 15:16:59 UTC
nxterm has been dropped from the distribution in 5.9beta and later.
Modern xterms do everything that nxterm did and more.