Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2051

Summary: PHP3 is not compiled with support for databases
Product: [Retired] Red Hat Linux Reporter: ipaul
Component: mod_php3Assignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-26 15:43:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ipaul 1999-04-08 07:59:14 UTC
I have installed mod_php3 and configured apache for it and
it works fine.
But when I try to conect to some databases it report some
errors (I have tried postgresql, sybase, mysql, oracle and
none of them have worked.).
It seems that mod_php3 is not compiled with support for
databases.
Please correct this.

Comment 1 Preston Brown 1999-04-08 14:35:59 UTC
Which database people have is highly subjective.  For this reason, if
someone is using a database backend with php3, they should rebuild the
RPM with support for that particular database enabled.

Comment 2 ipaul 1999-04-13 07:08:59 UTC
I realize that there are many databases under linux, but maybe there
should be compiled in PHP3 at least support for PostgresQL which ships
with RedHat.

Comment 3 Preston Brown 1999-04-13 18:26:59 UTC
If we did link against postgresql or something like that, people who
wanted to use the mod_php3 module would be *forced* to install
postgresql on their system, even if they didn't want to use it, to
satisfy the dependencies.

There are two solutions, neither of which is going to make it for 6.0:

1. have a number of subpackages to mod_php3 with different databases
supported in each subpackage.  Messy, large, but effective
2. get the mod_php3 people to dlopen database libraries, so new ones
can be added at runtime instead of compile time.  This is the real
solution.  Complain to the php3 people.

For now, people wanting database support more extensive than gdbm will
have to recompile.  Not the best solution, I know.

Comment 4 Preston Brown 1999-05-26 15:43:59 UTC
We will be making available php-3.0.8 as an update for Red Hat Linux,
which will include PostgreSQL support out of the box.

Comment 5 mcornick 1999-05-27 18:00:59 UTC
PostgreSQL didn't make it into mod_php3-3.0.8-1 due to a typo in the
spec file. The correct option to configure is --with-pgsql, not
--with-postgresql.

Comment 6 emarshal 1999-06-08 23:40:59 UTC
Someone might want to update the errata page, since it indicates that
the stock RPM provides PostgreSQL support, which it clearly doesn't.