Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 205

Summary: ipx frame types are wrong
Product: [Retired] Red Hat Linux Reporter: irm
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 5.2CC: athompso, irm, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-06 04:46:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description irm 1998-11-26 09:17:27 UTC
in ifup-ipx script underlines in next line should be
changes to dots

for frametype in 802_2 802_3 ETHERII SNAP ; do

Comment 1 David Lawrence 1998-11-29 23:42:59 UTC
I have verified this to be a bug in the initscripts. If autoprimary
and and autoframetype is enabled in /etc/sysconfig/network then the
interface will come up properly. If they are set to no then whatever
frametypes that are defined in the
/etc/sysconfig/network-scripts/ifcfg-ethx will not become activated.

Comment 2 Jeff Johnson 1998-12-06 04:46:59 UTC
Fixed in dist-6.0/initscripts-3.81-1.

Comment 3 Bill Nottingham 1999-01-15 16:31:59 UTC
*** Bug 205 has been marked as a duplicate of this bug. ***

After some checking, a shell hacker was a little whacky
with mixing eval/shell vars/program args.  He uses "802_3"
as the argument to ipx_interface, but it should be "802.3"
(for example, same true for other itfs).  I checked the
latest initscripts on rufus, and same bug.  Here's the
fixed file, ifup-ipx:

#!/bin/bash
# configures IPX on $1 if appropriate

PATH=/sbin:/usr/sbin:/bin:/usr/bin

if [ "$1" = "" ]; then
	echo "usage: $0 <net-device>"
	exit 1
fi

if [ ! -x /usr/bin/ipx_interface ] ; then
	# cannot configure IPX with non-existant utilities
	exit 0
fi

. /etc/sysconfig/network

case $IPX in yes|true) ;; *) exit 0 ;; esac

cd /etc/sysconfig/network-scripts
. network-functions

CONFIG=$1
[ -f "$CONFIG" ] || CONFIG=ifcfg-$CONFIG
source_config

for frametype in 802_2 802_3 ETHERII SNAP ; do
    # Yes, this kind of evaluation is really necessary to
do this.
    # Welcome to shell programming...  No, we were not
smoking some
    # particularly good floppies while we wrote this.  :-)
    case $(eval echo $(echo \$`echo IPXACTIVE_$frametype`))
in
	yes|true)
		case $(eval echo $(echo \$`echo
IPXPRIMARY_$frametype`)) in
		    yes|true) primary=-p ;;
		    *) primary= ;;
		esac
		# bozos... --bko
		case $frametype in
			802_2 ) real_frametype=802.2 ;;
			802_3 ) real_frametype=802.3 ;;
			ETHERII ) real_frametype=EtherII ;;
			* ) real_frametype=$frametype ;;
		esac
		/usr/bin/ipx_interface add $1 $primary
$real_frametype \
		  $(eval echo $(echo \$`echo
IPXNETNUM_$frametype`))
		;;
    esac
done

exit 0*** Bug 205 has been marked as a duplicate of this bug. ***

Due to a problem with the
/etc/sysconfig/network-scripts/ifup-ipx script IPX can not
start. I will email in a script from Jacques Gelinas that
will work.

 Dale

Comment 4 Jeff Johnson 1999-01-24 19:20:59 UTC
*** Bug 931 has been marked as a duplicate of this bug. ***

===================================================================
RCS file: ifup-ipx,v
retrieving revision 1.1
diff -u -r1.1 ifup-ipx
--- ifup-ipx    1999/01/23 21:04:49     1.1
+++ ifup-ipx    1999/01/23 21:09:19
@@ -34,7 +34,13 @@
                    yes|true) primary=-p ;;
                    *) primary= ;;
                esac
-               /usr/bin/ipx_interface add $1 $primary
$frametype \
+
+               case $frametype in
+                       802_2) fixedframetype='802.2' ;;
+                       802_3) fixedframetype='802.3' ;;
+               esac
+
+               /usr/bin/ipx_interface add $1 $primary
$fixedframetype \
                  $(eval echo $(echo \$`echo
IPXNETNUM_$frametype`))
                ;;
     esac