Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2048

Summary: Control-pannel error messages
Product: [Retired] Red Hat Linux Reporter: Jaroslaw Sosnicki <slavko>
Component: linuxconfAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 6.0CC: jack, slavko
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-04-09 18:59:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jaroslaw Sosnicki 1999-04-08 05:46:04 UTC
Server is as follows:
Linux www.slavko.com 2.2.5-4smp #1 SMP Tue Apr 6 19:29:30
EDT 1999 i686 unknown

I downloaded beta3 set and I am getting the foloving errors
when execution control-panel

[root@www bin]# control-panel
Red Hat Linux netcfg 2.18
Copyright (C) 1996, 1997 Red Hat Software
Redistributable under the terms of the GNU General Public
License
Red Hat Linux kernelcfg 0.4
Copyright (C) 1996 Red Hat Software
Redistributable under the terms of the GNU General Public
License
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file
gtkcombo.c: line 817 (gtk_combo_set_popdown_strings):
assertion `strings != NULL' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file
gtkcombo.c: line 817 (gtk_combo_set_popdown_strings):
assertion `strings != NULL' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file
gtkcombo.c: line 817 (gtk_combo_set_popdown_strings):
assertion `strings != NULL' failed.

Comment 1 Preston Brown 1999-04-08 14:45:59 UTC
this looks like a bug in gnome-linuxconf.

Comment 2 Michael K. Johnson 1999-04-08 14:56:59 UTC
I can't reproduce this, but then, I don't know what you did within
linuxconf to get this complaint from Gtk+.  Please tell me what you
did within linuxconf so that I can look for and fix these errors.
Thanks!

------- Email Received From  Jaroslaw Sosnicki <slavko@home.com> 04/08/99 11:41 -------


------- Email Received From  Jaroslaw Sosnicki <slavko@home.com> 04/08/99 20:53 -------

Comment 3 Michael K. Johnson 1999-04-09 16:03:59 UTC
Thank you very much for the excellent information.  I think that
this is a bug in linuxconf rather than in gnome-linuxconf; Jacques
and I are discussing that now.  In any case, the bug is only cosmetic;
gnome-linuxconf and linuxconf should function fine.  Gtk+ is only
complaining reasonably about a weird condition.

Jacques, this is the bug that I just sent you email about,
where combo boxes aren't getting filled in with any information
in dnsconf.

------- Email Received From  Jacques Gelinas <jack@solucorp.qc.ca> 04/09/99 14:18 -------

Comment 4 Michael K. Johnson 1999-04-09 18:59:59 UTC
fixed in linuxconf-1.14r4-3