Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2042

Summary: Mangled manpage
Product: [Retired] Red Hat Linux Reporter: francis+rhbz
Component: byaccAssignee: Preston Brown <pbrown>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-04-07 22:27:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description francis+rhbz 1999-04-07 20:26:20 UTC
The manpage for yacc(1) comes out slightly mangled, because,
wherever it wants to talk about #line directives, the
original file (/usr/man/man1/yacc.1) uses the text "\#line";
apparently the \ isn't sufficient to keep the # from acting
as a comment, and troff chops off the rest of the line.  To
see the effect, look at the description of the "-l" option.

I've seen other mangled manpages on RedHat, too; I don't
remember now which ones they were, but I'll keep a lookout
in the future to see if they're the same problem.

Comment 1 Preston Brown 1999-04-07 22:27:59 UTC
fixed in byacc-1.9-11 and later. thanks for the report.