Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 203

Summary: XFree86 Server has problems with monitor and(or) Video card
Product: [Retired] Red Hat Linux Reporter: Red Hat Bugzilla <bugzilla>
Component: XFree86Assignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-10 17:09:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Red Hat Bugzilla 1998-11-25 22:56:37 UTC
I have been having some serious problems getting X to work
with my Video/Monitor.  My monitor is an NEC/4FGe and video
card is a Diamond Stealth 3d 3000 w/4 mb.  I have tried the
Xconfigurator during the install (ends up with a complete
system halt) and also tried Xconfigurator after install
(installed rpm and ran...ended in system halt)  I have also
tried XF86Setup with the Correct Refresh rates for my
monitor and right amount of ram for my video card (4).  I
have tried everything short of compiling my own server,
which will be my next step just to see what is going on with
the server.  I have tried the Scitech Display Doctor Beta 3
for linux and it seems to work except colors are very
"funky" I have been using RedHat since 4.1 and never had
these problems with it I know my hardware works and worked
fine for the previous installations.  I do not upgrade I
just reformat and install.

Comment 1 Red Hat Bugzilla 1998-11-29 22:42:59 UTC
Alot of the S3 Virge support has been rolled over into the SVGA server
instead of using the old S3V server. Try choosing UNLISTED from the
card selection list of Xconfigurator. Then choose the SVGA server.
After that answer the remaining questions the same you normally would.
When you startx it should say what card is detected and it should
work. Let us know what happens.

Comment 2 Red Hat Bugzilla 1998-12-09 16:25:59 UTC
Xconfigurator on Red Hat 5.2 doesn't let me choose any card, it just
detectes my card and forces me to go on with the installation. How can
I choose the SVGA server?

Comment 3 Red Hat Bugzilla 1998-12-10 17:09:59 UTC
I apologize. I should have stated in my last comment how to allow you
to choose from the list. When you insert the first boot disk and boot
the system, you need to type expert at the boot: prompt. This will
allow you to explicitly choose which server you want to be installed.