Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1989

Summary: FTP Install bug
Product: [Retired] Red Hat Linux Reporter: nathan
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-04-07 20:26:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description nathan 1999-04-04 23:21:54 UTC
This tftpboot.img on SPARC, I assume the installer is the
same across architectures.

When installing over an FTP server, the installer connects
first (to download base/hdlist and base/comp). Then it
presents the list of packages, waits for the user to check
which packages he/she wants -- then assumes the connection
to the FTP server is still open. In reality, package
selection may take a bit longer than 300 seconds (or even
900 seconds). At this point, the installer is unable to
get even the first package, dies, and shuts down.

Verified: just accepting the default package selection,
the installation gets underway with no problems.

Fix: disconnect before, and reconnect after, package
selection to the ftp server

Comment 1 David Lawrence 1999-04-07 20:26:59 UTC
This should be fixed in the next release.