Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1986

Summary: cron skips jobs on first day of DST
Product: [Retired] Red Hat Linux Reporter: hargrove
Component: vixie-cronAssignee: Crutcher Dunnavant <crutcher>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5.2CC: jss
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-04-10 22:01:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description hargrove 1999-04-04 20:04:17 UTC
Because the clock doesn't pass through the times 2:00-2:59
on the first day of daylight savings time, jobs (such as my
daily backups!) that are scheduled to begin anytime in this
one hour window are skipped.

Arguably this is correct in the sense that these times don't
exist, but if this behavior is to be considerd "normal",
then the man page should warn users about this.

Comment 1 David Lawrence 1999-04-06 19:53:59 UTC
Your suggestion has been passed on to a developer for further review.

Comment 2 Michael K. Johnson 1999-04-14 17:17:59 UTC
I have reviewed the Single Unix Specification definition of crontab
(it doesn't talk about cron specifically, but the crontab definition
talks about the crontab format as well) and there is no indication
that cron should magically re-schedule jobs that are scheduled for a
non-existant time.  Indeed, it is not clear what the right thing to
do would be if cron tried to shuffle the schedules.

I have reclassified this bug report as a documentation bug report
and we'll change the man page to explicitly mention that cron will
not run jobs during times that do not exist, such as during daylight
savings time conversions.

Comment 3 Michael K. Johnson 1999-04-14 17:40:59 UTC
Man page updated with this information in vixie-cron-3.0.1-32

Comment 4 Jeremy Sanders 2002-11-22 12:41:41 UTC
Following up on this, in RedHat 7.3, the cron manpage makes no mention of
daylight saving time. It is not clear whether some jobs may be run twice or not
at all.