Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 198460

Summary: Package scim lacks IPv6 support
Product: [Fedora] Fedora Reporter: Peter Vrabec <pvrabec>
Component: scimAssignee: Peng Huang <phuang>
Status: CLOSED DEFERRED QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: eng-i18n-bugs, jpazdziora, mbacovsk, petersen
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-08 04:48:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150223    

Description Peter Vrabec 2006-07-11 12:39:27 UTC
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
		
This package seems to lack IPv6 support.

Comment 1 Jens Petersen 2006-07-12 02:07:19 UTC
SCIM uses unix domain sockets by default and we have never tested it
over tcp sockets.  So does this still need to be done for FC6?

Comment 2 Jan Pazdziora 2006-07-12 05:43:58 UTC
There seems to be a code in scim-1.4.4-20060704/src/scim_socket.cpp file in
SocketAddress::SocketAddressImpl::set_address method that checks

else  if ((varlist [0] == "tcp" || varlist [0] == "inet") 

and based on that creates an AF_INET socket. Also, the __gethostname uses
gethostbyname_r, a IPv4-only function. Using getaddrinfo might be needed.

Could you check if the TCP code is ever used by other parts of scim?

Comment 3 Jens Petersen 2006-07-25 01:12:39 UTC
It is only used if one explicitly configures scim to use a tcp socket
instead of a unix one, but we've never actually tested that codepath...

Comment 6 Jens Petersen 2006-09-26 05:09:07 UTC
Lower to FC6 Target since net code is not used by default configuration
and indeed we have never even tested it.

Comment 7 Jens Petersen 2007-11-08 04:48:30 UTC
I am going to defer this for now, since network socket support
is a low priority anyway.