Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 192582

Summary: hp-toolbox does not save printer settings
Product: [Fedora] Fedora Reporter: David Highley <dhighley>
Component: hplipAssignee: Tim Waugh <twaugh>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: FC6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-19 04:15:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150225    

Description David Highley 2006-05-21 03:54:39 UTC
Description of problem:
Set reverse print order and duplex long edge but settings are not saved.

Version-Release number of selected component (if applicable):
0.9.11

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Do not get reverse print order or duplex printing.


Expected results:


Additional info:
I also had to copy printer models from the source distribution as they were
missing  and the /usr/share/doc/hplip-0.9.11 files are missing.

Comment 1 Tim Waugh 2006-05-22 15:19:02 UTC
Can you please talk me through how you set those options?  What buttons did you
press, etc?

> I also had to copy printer models from the source distribution as they
> were missing  and the /usr/share/doc/hplip-0.9.11 files are missing.

Please file separate bug reports for those problems.  It is much easier to keep
track of which problems are fixed when there is one bug per report.  Thanks.

Comment 2 David Highley 2006-05-23 03:21:51 UTC
hp-toolbox
Functions->Print...
x Reverse print order
Duplex->Long edge (standard)
Close

I must say that I do not see a save or apply button. I now find that if
I go to Tools & Settings->Configure Print Settings it takes you to the
Cups printer administration page where you can Set Printer Options. I
see a setting for duplex but not reverse print order. If you set the
duplex option and then look in hp-toolbox you do not see duplex printing
enabled and in fact if you print you do not get duplex printing.

Comment 3 David Highley 2006-05-23 04:26:18 UTC
I have a partial fix. I went to
http://www.linuxprinting.org/printer_list.cgi?make=HP

Down loaded the Officejet 7300 PPD file.
cat Officejet7300.ppd >/etc/cups/ppd/<printer>
service hplip restart
service cups restart

Changing the settings in hp-toolbox does not seem to stick. So I went to Cups
and changed the printer settings for duplex printing and I now get duplex
printing. No option for reverse print order.

Comment 4 David Highley 2007-01-19 04:15:18 UTC
Issue seems to be taken care of by cups now, verified on hplip-1.6.10-1.fc6.4
and cups-1.2.7-1.5.fc6. Still wish there was a menu for hp-toolbox.

Comment 5 Tim Waugh 2007-01-19 11:27:39 UTC
Thanks for testing!