Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 192

Summary: kickstart with bootp doesn't config static network
Product: [Retired] Red Hat Linux Reporter: bentlema
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 5.2CC: adam, jorma.laaksonen, marty.trey
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-10 18:39:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description bentlema 1998-11-25 02:08:04 UTC
I'm using a BOOTP server to obtain the network info for
a client doing a kickstart.  The client obtains the
kickstart file just fine, reads everything in, NFS-mounts up
the RedHat5.2 distribution over NFS, and proceeds with the
installation.  Even though I'm specifying a "network
--bootproto static ..." line in my kickstart client config
file, the machines comes up after the install and contacts
the BOOTP server once again to obtain its networking
parameters.

I'm having to manually configure the following files in the
post-installation section to get around this bug:

     /etc/sysconfig/network
     /etc/sysconfig/network-scripts/ifcfg-eth0
     /etc/hosts
     /etc/resolv.conf

The interesting thing is if I take the exact same kickstart
config file and copy it onto the bootdisk, and do a "linux
ks=floppy" the networking is configured correctly.

It appears that the kickstart installation program is making
the incorrect assumption that If I'm using a BOOTP server
during the install phase, that I will always want to use a
BOOTP server to obtain network config info.  We should be
able to use a BOOTP server to do obtain a clients network
configuration (so that we can install the distribution over
NFS) and configure networking statically so that upon reboot
the machine can boot up without BOOTP.

I can provide you with my kickstart config file and bootptab
file if that helps.

Comment 1 David Lawrence 1998-11-30 20:19:59 UTC
I have verified this to be a bug. This is being assigned to a
developer.

Comment 2 Preston Brown 1999-03-18 15:36:59 UTC
Matt? Any progress on this one?

Comment 3 Jay Turner 1999-07-07 13:31:59 UTC
*** Bug 3920 has been marked as a duplicate of this bug. ***

Using the following kickstart file, after installation of
all packages, during the network configuraion step, the
install cannot do a reverse name lookup to determine the
host and domain name.  Upon further inspection the network
device driver is being installed and eth0 exists, but is not
configured.
--------- begin ks.cfg ----------
lang en
device ethernet 3c59x
network --bootproto static --ip 192.168.73.7 --netmask
255.255.255.0 --gateway 192.168.73.254 --nameserver
192.168.72.140
cdrom
keyboard us

zerombr yes
clearpart --all
#
# part <mntpt> --size <size in megs> [--grow] [--maxsize
<size in megs>]
#
part / --size 250
part swap --size 64
part /usr --size 800 --grow --maxsize 1200
part /var --size 500 --grow --maxsize 800
part /tmp --size 100 --grow --maxsize 800

install
mouse msintellips/2
timezone US/Eastern
xconfig --monitor "Generic08"
skipx yes
auth --useshadow --enablemd5
lilo --location mbr

# '@ component' may be used to include entire components
%packages
@ Printer Support
@ KDE
@ DOS/Windows Connectivity
@ SMB (Samba) Connectivity
@ DNS Name Server
@ Network Management Workstation
@ C Development
@ Development Libraries
@ C++ Development
@ Extra Documentation
--------- end ks.cfg ----------


------- Additional Comments From jturner@redhat.com  07/06/99 15:51 -------
One thing that might be causing what you are seeing is the fact that
it appears as if the network line of the config file is not on one
single line.  It has to be on the same line in order for the install
to process it.  As it is (where it appears to be on different lines)
the nameserver is not getting set and therefore no name lookup!
Reopen this bug if you still have problems after modifying this.

------- Additional Comments From Marty.Trey@MED.VA.GOV  07/07/99 06:52 -------
The network directive is on one single line.

Comment 4 Jay Turner 1999-07-07 15:10:59 UTC
*** Bug 2724 has been marked as a duplicate of this bug. ***

When doing a kickstart install, using a DHCP/NFS combination
for the install, if the kickstart file specifies network
--bootproto static in the config file, the installer fails
to change the ethernet config from BOOTP/DHCP to static.

Relevant bits of the kickstart file follows:

network --bootproto static --ip 162.42.150.62 --netmask
255.255.255.0 --gateway 162.42.150.1 --nameserver
162.42.150.33
(all on one line, of course)

After a reboot, you will notice that the
/etc/sysconfig/network and
/etc/sysconfig/network-scripts/ifcfg-eth0 files have failed
to change to static from BOOTP/DHCP.

Adam

Comment 5 Jay Turner 2000-02-10 18:39:59 UTC
This is fixed in the latest installer (available in beta)