Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1903

Summary: damage to your existing installation of Solaris for x86
Product: [Retired] Red Hat Linux Reporter: ipaul
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-29 18:39:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ipaul 1999-03-31 10:25:10 UTC
If you have already installed a Solaris for x86 on your
hardisk, then the kernel (2.2.x) will see and configure
aditional partitions devices for Solaris for X86 partition
table (hda5 , hda6 , etc )
because new kernels can see Solaris for intel partition
tables.
The problem is that current fdisk and Disk Druid does not
recognize the Solaris partition table that kernel does.

So, in this case the Disk Druid will make a partition (for
instance /dev/hda5) but when it came to formating and
mounting, the kernel will format and mount the solaris
slices.

In this way I managed to loose all my data on the hardisk
:-(

It is a very severe bug of Disk Druid I think.

The solution can  be aproached in two ways:

1) Compile the kernel without Solaris partition support. Bad
idea because you cannot add suport for Solaris partition
later without changing lilo configuration file. And I need
solaris partition support.

2) Make Disk Druid "see" and interpret correctly the Solaris
intel partition table.

Comment 1 Preston Brown 1999-03-31 22:46:59 UTC
Matt this is a relatively easy yet important fix.

Comment 2 Matt Wilson 1999-04-01 05:08:59 UTC
solaris partitioning support will be turned off.

Comment 3 ipaul 1999-04-01 06:44:59 UTC
Re: solaris partitioning support will be turned off.

Turning off solaris partition table support is the easy way, but in
that case we can't use solaris for x86 slices very easy because you
have to disable solaris partition support both in the installer and in
the sistem because other way the system could not boot properly.
In this case, if I want solaris partition support I have to recompile
the kernel with solaris partition support and to modify lilo.conf to
boot properly, guessing what will become the actual root partition.

The best way to fix this is to make Disk Druid and maybe fdisk to see
and corecty interpret the solaris for x86 partitin tables.

Thanks in advance for understanding.

Comment 4 Matt Wilson 1999-04-15 16:11:59 UTC
solaris x86 support in disk druid is a very low priority.  This is the
only request I've ever had for it.