Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1888

Summary: inn-2.2-3 is rather broken (e.g. missing initscript)
Product: [Retired] Red Hat Linux Reporter: Christian Hechelmann <drdisk>
Component: innAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: drdisk
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-30 20:44:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Christian Hechelmann 1999-03-30 16:54:14 UTC
inn-2.2-3 is rather broken.

Things I've found by a quick look:

- it lacks the init script and everything else below
  /etc/rc.d
- the paths in all cron scripts are broken, since the
  binaries aren't in /usr/lib/news/bin but in /usr/bin
- the cron scripts do not check if inn is enabled at all
  thus producing lots of mail from cron.
  FIX: put "/sbin/chkconfig innd && " in front of commands
- package does not use %defattr and is generally only
  buildable by root. Bad.

Comment 1 Preston Brown 1999-03-30 20:43:59 UTC
inn-2.3-7 fixes the following issues:

* init script problem, as well as rc.d scripts missing
* cron job path issues
* cron jobs check to see if innd is enabledsorry, that is inn-2.2-7.