Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1866

Summary: ntsysv does not show proper "levels"
Product: [Retired] Red Hat Linux Reporter: Stephen John Smoogen <smooge>
Component: distributionAssignee: David Lawrence <dkl>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: athompso
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-29 16:00:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Stephen John Smoogen 1999-03-29 15:50:06 UTC
If you log in as single user (LILO linux single) and run
ntsysv to change application run levels it shows all
connections to be blank [ ] versus what they might be
running at all.

While this might be intended behaviour it does not fit older
behavior where ntsysv would show what applications would
generally run. This gave users an easy tool to turn off
applications that might cause problems if they tried to
start the machine in run level 3 or 5.

ntsysv-1.0.3-1

Comment 1 Bill Nottingham 1999-03-29 16:00:59 UTC
This is a behavior change, which is documented in the
man page. To edit a particular runlevel, do
'ntsysv --levels 123', for example. Basically, the
problem we're facing is how to avoid accidentally turning
on X in runlevel 3. :(

Comment 2 Adam Thompson 1999-04-04 22:51:59 UTC
Simplest way I've seen (can't remember which OS) takes into account
the fact that there is (generally) a fixed upper bound on the number
of runlevels.  The ntsysv screen could be redone to look something
like this:

      +-----------------------+
      | Default Runlevel: [3] |
      +-----------------------+
+-PkgName--[1]-[2]-[3]-[4]-[5]-[6]-[7]-[8]-[9]-+
| apmd     [X] [X] [X] [X] [X] [ ] [ ] [ ] [ ] |
| ....                                         |
| xdm      [ ] [ ] [ ] [ ] [X] [ ] [ ] [ ] [ ] |
+----------------------------------------------+
        <<OK>>  <<CANCEL>>

I don't know what range of runlevels SysVinit can handle, so this may
or may not be practical.  Worth noting that a "typical" RedHat system
only worries about runlevels 0, 3, 5 and 6. (I think. :-)