Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 182512

Summary: Amaya does not build on x86_64
Product: [Fedora] Fedora Reporter: Aurelien Bompard <gauret>
Component: amayaAssignee: Paul F. Johnson <paul>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: extras-qa, katzj, paul
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-06-19 06:00:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 179259    

Description Aurelien Bompard 2006-02-22 22:36:39 UTC
Amaya does not build on x86_64. This arch has been ExcludeArch'ed

Error:
../../thotlib/image/xpmcreate.c: In function 'int ParseAndPutPixels(xpmData*,
unsigned int, unsigned int, unsigned int, unsigned int, XpmColor*,
xpmHashTable*, XImage*, Pixel*, XImage*, Pixel*)':
../../thotlib/image/xpmcreate.c:2429: error: cast from 'void*' to 'unsigned int'
loses precision
../../thotlib/image/xpmcreate.c:2432: error: cast from 'void*' to 'unsigned int'
loses precision
make[1]: *** [image/xpmcreate.o] Error 1

Comment 1 Ville Skyttä 2006-02-23 06:53:23 UTC
The above errors look like the code needs to change for example so that it uses
the standard uintptr_t when casting pointers.

Comment 2 Aurelien Bompard 2006-05-06 08:00:42 UTC
*** Bug 158888 has been marked as a duplicate of this bug. ***

Comment 3 Paul F. Johnson 2006-06-18 22:03:07 UTC
Can you close this bug please (or reassign it to me)?

Currently, amaya fails to build due to a bug in libpng (png_read_destroy not
found), but gets past the point listed above.