Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 178110

Summary: Some toolkit cleanups
Product: [Fedora] Fedora Reporter: Christopher Aillon <caillon>
Component: gtk2Assignee: Matthias Clasen <mclasen>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: cworth
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-01-24 21:27:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150221    

Description Christopher Aillon 2006-01-17 20:42:58 UTC
We should use bullets for password dialogs instead of asterisks and kill the
checkbox animation.

Comment 1 Matthias Clasen 2006-01-17 20:53:38 UTC
The invisible character for password entries is not a theme properties, each
application can pick its own. Maybe that sucks...

For the checkbox animation, cworth had a cute drawing animation, which actually
strokes the check. That was much nicer than the fading in.

Comment 2 Christopher Aillon 2006-01-18 19:48:30 UTC
Matthias, sure, but if the app doesn't pick a character, we default to '*'
right?  Can we just change the default?

Comment 3 Matthias Clasen 2006-01-19 19:31:57 UTC
We can patch gtk to use a different character by default, if you can convince me
that that character will be available in all fonts we ship.

Comment 4 Matthias Clasen 2006-01-19 19:58:01 UTC
The relevant upstream bugs are 

http://bugzilla.gnome.org/show_bug.cgi?id=83935
http://bugzilla.gnome.org/show_bug.cgi?id=307304

where Owen expresses some general opposition to changing the default.
But I'm fine with trying this out in Fedora. We can always change it back
if it causes problems with certain fonts.

Comment 5 Christopher Aillon 2006-01-20 01:57:00 UTC
I built a gtk2 into rawhide with unicode 2022 as the default invisible
character.  We'll revert if its a problem.  We still ought to do something about
the checkbox animation.

Comment 6 Matthias Clasen 2006-01-20 14:23:55 UTC
You can ask cworth for his checkbox-stroking patch, I know he had one at some
point. But even with that, it is still inconsistent. Regular checkboxes are
animated, but checkmenuitems and toggle cells in treeviews seem not

Comment 7 Christopher Aillon 2006-01-23 18:42:10 UTC
Carl, your thoughts?

Comment 9 Christopher Aillon 2006-01-24 21:27:33 UTC
Okay, looks like the animations have been disabled for now.  Closing this one out.