Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 173322

Summary: yumdownloader doesent work properly with extras src rpms by default
Product: [Fedora] Fedora Reporter: Rudolf Kastl <che666>
Component: fedora-releaseAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: extras-qa, ianburrell, mattdm, scop, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-22 23:29:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 163149    
Bug Blocks:    

Description Rudolf Kastl 2005-11-16 10:16:58 UTC
Description of problem:
with default configuration its not possible to yumdownloader --source dosbox.
should work in my eyes since extras is enabled by default.

Version-Release number of selected component (if applicable):
latest fc4 rel

How reproducible:
always

Steps to Reproduce:
1. install fedora core 4
2. yumdownloader --source dosbox (for example)
  
Actual results:
yumdownloader --source dosbox
Cannot find a valid baseurl for repo: updates-released
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 130, in ?
    main()
  File "/usr/bin/yumdownloader", line 70, in main
    my = initYum(opts.source)
  File "/usr/bin/yumdownloader", line 43, in initYum
    my.doRepoSetup()
  File "/usr/lib/python2.4/site-packages/PIL/__init__.py", line 225, in doRepoSetup

  File "repos.py", line 544, in baseurlSetup
  File "repos.py", line 427, in check
yum.Errors.RepoError: Cannot find a valid baseurl for repo: updates-released

Expected results:
yumdownloader should use the yum configuration properly (mirrorlists etc) to be
able to grab src files from all enabled repos.

Additional info:
no clue where the bug occurs i was too lazy to look into the source.

Comment 1 Matthew Miller 2005-11-28 12:46:06 UTC
This isn't really a bug in yum-utils but in the lack of configuration files for
the source repo tree. This ought to be moved to component "fedora-release", but
there's no bugzilla component for that. (?!)

Comment 2 Seth Vidal 2005-11-28 13:19:17 UTC
reassigning

Comment 3 Rudolf Kastl 2005-11-28 13:23:20 UTC
well also the exception should be handled properly.

Comment 4 Matthew Miller 2005-11-28 13:49:41 UTC
Okay, sure. :)

Comment 5 Rudolf Kastl 2005-12-01 17:57:06 UTC
problem also occurs with updates repository

Comment 6 Jesse Keating 2006-01-25 00:03:54 UTC
I'm going to look into having a sources repo configured in the release and
available on the mirrors for FC5.

Comment 7 Ian Burrell 2006-01-31 05:46:09 UTC
It would also be good to get repodata for the SRPMS directories for base and
updates-released.

Also, I would suggest using a consistent naming for the repositories.  Like
base-source, updates-sources, extras-source.  That way, doing
'--enablerepo=\*-source' would select all the source repos.  It could even be
done automatically by 'yumdownloader --source'.


Comment 8 Jesse Keating 2006-02-22 23:29:34 UTC
Fedora-release package in rawhide includes -source repos for base, updates,
extras, development.  Also -debuginfo for these.  repodata is generated for
these dirs too.