Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1699

Summary: kickstart doesn't work with a SCSI CD
Product: [Retired] Red Hat Linux Reporter: lyonsa
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-02 18:11:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description lyonsa 1999-03-23 19:37:20 UTC
Although I can install manually, I can't use kickstart to
rebuild a SCSI based system.  It seems to fail when it
should be mounting the CD.  The same ks.cfg file works fine
on an IDE system.

Comment 1 David Lawrence 1999-03-23 22:17:59 UTC
I was able to get kickstart to work properly with a toshiba scsi cdrom
w/ Buslogic PCI scsi adaptor. I was able to perform an upgrade and
install kickstart file stored on the boot floppy and type linux
ks=floppy at the boot prompt.

Comment 2 lyonsa 1999-03-26 23:22:59 UTC
With an Adaptec 2940 SCSI controller and a SCSI CDROM kickstart does
not seem to load the driver properly OR the kickstart process does not
realize that the driver is loaded.

linux ks=floppy gets to probing fine, identifies the 2940 then returns
to the Load Module screen.

ALT-F3 shows these lines at the end:
* no scsi devices are available
* in loadDeviceDriver, ks = 1, typName = SCSI
* pci probing for SCSI devices
* pci probe found 1 SCSI devices
* found driver for Adaptec 2740, 2840, 2940
* running: /bin/insmod /bin/insmod /modules/aic7xxx.o
* in loadDeviceDriver, ks = 1, typName = SCSI
* pci probing for SCSI devices
* pci probe found 1 SCSI devices

ALT-F4 shows the proper output for this module.  All SCSI devices seem
to be identified properly.

Of course trying to load the module again fails because the module is
already loaded.

Comment 3 Jay Turner 1999-07-02 18:11:59 UTC
This has been fixed in 6.0.  Tested in lab on 2940U2W card with no
problems.