Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1695346

Summary: [abrt] bcc-tools: __init__(): __init__.py:320:__init__:Exception: Failed to compile BPF text
Product: [Fedora] Fedora Reporter: Jordan Christiansen <xordspar0>
Component: bccAssignee: Jiri Olsa <jolsa>
Status: NEW --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: acaringi, jolsa, rdossant, skozina
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/c0c0c5ff0350cdd6ec8f65c7e2dfdd8ff6e5fcab
Whiteboard: abrt_hash:2515dea06520c6cbec6a73fc811ea085680a21ba;VARIANT_ID=workstation;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace
none
File: cgroup
none
File: cpuinfo
none
File: environ
none
File: mountinfo
none
File: namespaces
none
File: open_fds none

Description Jordan Christiansen 2019-04-02 20:59:21 UTC
Description of problem:
This was a fresh install of Fedora 29 that I hadn't installed any updates on yet. Installing bcc-tools pulled in kernel-modules and kernel-devel, but these packages didn't have the same version as the installed kernel. After running a full "dnf upgrade" and rebooting, the bcc tools worked fine.

Version-Release number of selected component:
bcc-tools-0.8.0-1.fc29

Additional info:
reporter:       libreport-2.10.0
cmdline:        /usr/bin/python3 /usr/share/bcc/tools/memleak
crash_function: __init__
exception_type: Exception
executable:     /usr/share/bcc/tools/memleak
interpreter:    python3-3.7.2-4.fc29.x86_64
kernel:         4.20.16-200.fc29.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
#1 [/usr/lib/python3.7/site-packages/bcc/__init__.py:320] __init__
#2 [/usr/share/bcc/tools/memleak:394] <module>

Comment 1 Jordan Christiansen 2019-04-02 20:59:24 UTC
Created attachment 1551153 [details]
File: backtrace

Comment 2 Jordan Christiansen 2019-04-02 20:59:25 UTC
Created attachment 1551154 [details]
File: cgroup

Comment 3 Jordan Christiansen 2019-04-02 20:59:26 UTC
Created attachment 1551155 [details]
File: cpuinfo

Comment 4 Jordan Christiansen 2019-04-02 20:59:27 UTC
Created attachment 1551156 [details]
File: environ

Comment 5 Jordan Christiansen 2019-04-02 20:59:28 UTC
Created attachment 1551157 [details]
File: mountinfo

Comment 6 Jordan Christiansen 2019-04-02 20:59:29 UTC
Created attachment 1551158 [details]
File: namespaces

Comment 7 Jordan Christiansen 2019-04-02 20:59:30 UTC
Created attachment 1551159 [details]
File: open_fds

Comment 8 Rafael Fonseca 2019-04-02 22:42:18 UTC
Thank you for the bug report. This is a known issue and, unfortunately, there is no satisfactory solution.

Ideally, bcc-tools would require kernel-devel for all versions of installed kernels, but I don't think rpm dependencies allow us to do that. Installing the kernel-devel version of the running kernel would still fail if someone reboots to a third kernel version. However, I don't think rpm dependencies allow us to do that either. It could be done in a post install script, but I don't know if that's recommended. Moreover, whatever we do in a post install script won't work when someone installs another kernel version afterwards.