Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1690980

Summary: kernel-5.0.3-200.fc29.x86_64 : dracut fails
Product: [Fedora] Fedora Reporter: Christian Labisch <clnetbox>
Component: dracutAssignee: dracut-maint-list
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 29CC: airlied, alex.ploumistos, bskeggs, dracut-maint-list, genes1122, hdegoede, ichavero, itamar, jarodwilson, jeremy, jglisse, john.j5live, jonathan, josef, kernel-maint, labbott, linville, mchehab, mjg59, steved, th.neuber, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-05 08:51:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
/var/spool/abrt/ccpp-2019-03-20-15:38:09.696560-24300 none

Description Christian Labisch 2019-03-20 15:39:15 UTC
Created attachment 1546153 [details]
/var/spool/abrt/ccpp-2019-03-20-15:38:09.696560-24300

After installing kernel 5.0.3 abrt reports a dracut related crash (see attachment).

Running sudo dracut /boot/initramfs-5.0.3-200.fc29.x86_64.img generates the error :

/usr/lib/dracut/dracut-init.sh: line 969: 18566 Segmentation fault (core dumped) $DRACUT_INSTALL ${initdir:+-D "$initdir"} ${loginstall:+-L "$loginstall"} ${hostonly:+-H} ${omit_drivers:+-N "$omit_drivers"} ${srcmods:+--kerneldir "$srcmods"} ${_optional:+-o} ${_silent:+--silent} -m "$@"

dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.qKAmEf/initramfs -H --kerneldir /lib/modules/5.0.3-200.fc29.x86_64/ -o -m =drivers/net/phy =drivers/net/team =drivers/net/ethernet ecb arc4 bridge stp llc ipv6 bonding 8021q ipvlan macvlan af_packet virtio_net xennet

Comment 1 Laura Abbott 2019-03-20 16:28:13 UTC
I need the dracut team to do the first pass of looking at this and seeing what's going on

Comment 2 Gene Snider 2019-03-20 20:15:37 UTC
This bug is a duplicate of 1685932, which contains an abort analysis.

Gene

Comment 3 Christian Labisch 2019-03-26 15:06:49 UTC
https://koji.fedoraproject.org/koji/buildinfo?buildID=1238962 solves the problem ... dracut finishes without errors.

Comment 4 Christian Labisch 2019-03-29 13:10:37 UTC
I think this bug ticket can be closed now.