Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 169054

Summary: pm-utils is missing a laptop-mode type script
Product: [Fedora] Fedora Reporter: Richard Hughes <richard>
Component: pm-utilsAssignee: Phil Knirsch <pknirsch>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bnocera, davidz, notting, rvokal
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-24 12:24:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150221    
Attachments:
Description Flags
Example file that could be used in pm-utils none

Description Richard Hughes 2005-09-22 16:32:29 UTC
Description of problem:
pm-utils has hibernate and suspend scripts that work really well in a fedora
core rawhide system.
It does not have a script to change the various vm arguments like the script
laptop-tools does, e.g.

echo $DISK_IDLE_SECS > /proc/sys/vm/laptop_mode

Version-Release number of selected component (if applicable):
pm-utils-0.04-1

Additional info:
HAL will call this script for SetLowPower() dbus methods that is invoked on
*only* laptops.

Comment 1 Richard Hughes 2005-09-22 16:32:30 UTC
Created attachment 119149 [details]
Example file that could be used in pm-utils

Comment 2 Richard Hughes 2005-09-28 16:52:47 UTC
Should this be a blocker for FC5?

Comment 3 Bill Nottingham 2005-09-28 17:03:09 UTC
It's on the target list for FC5.

Comment 4 Richard Hughes 2006-02-11 15:05:20 UTC
Any news? FC5t3 will be out soon, and it's simply a case of adding one file to a
package... This single file makes laptop-mode tools obsolete, and also means
gnome-power-manager doesn't spit out errors from hal about no LowPowerMode script.
Hal currently looks for pm-powersave, so if the new script is called that name,
then it will just work with HAL. If you change the name to something like
pm-laptopmode, then I can trivially patch HAL - it's up to you.
SuSE already support laptop-mode by default in the powersaved package.

Comment 5 David Zeuthen 2006-02-12 17:29:57 UTC
Bill, Phil, could we put this in? It makes a lot of sense to include it and it
seems like pretty low risk.

Comment 6 David Zeuthen 2006-02-23 21:44:01 UTC
Ping? Can we do this please? It seems like extremely low risk since a number of
our competitors is already doing this.

Comment 7 Phil Knirsch 2006-02-24 08:41:13 UTC
Yeah, will put it in today.

Read ya, Phil

Comment 8 Richard Hughes 2006-02-24 17:09:46 UTC
What's the script called, then I can send a patch for HAL. Thanks for doing this.

Comment 9 David Zeuthen 2006-02-24 17:49:27 UTC
I've already fix hal upstream. The hal-0.5.7-1 Fedora package will include this
patch.

--- hal-system-power-set-power-save	2005/11/29 17:47:54	1.4
+++ hal-system-power-set-power-save	2006/02/24 16:47:11	1.5
@@ -25,10 +25,10 @@
 elif [ -f /etc/redhat-release ] || [ -f /etc/fedora-release ] ; then
 	if [ -x "/usr/sbin/pm-powersave" ] ; then
 		if [ $value = "true" ]; then
-			/usr/sbin/pm-powersave on
+			/usr/sbin/pm-powersave true
 			RET=$?
 		elif [ $value = "false" ]; then
-			/usr/sbin/pm-powersave off
+			/usr/sbin/pm-powersave false
 			RET=$?
 		fi
 	else


Comment 10 Richard Hughes 2006-02-24 18:34:07 UTC
Good man, thanks for doing this.