Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1689907

Summary: Undercloud: zaqar containers healthcheck missing
Product: Red Hat OpenStack Reporter: Sasha Smolyak <ssmolyak>
Component: openstack-zaqarAssignee: RHOS Maint <rhos-maint>
Status: NEW --- QA Contact: nlevinki <nlevinki>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15.0 (Stein)CC: apevec, jschluet, lhh, rrasouli
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sasha Smolyak 2019-03-18 12:17:04 UTC
Description of problem:
Undercloud: when running healthcheck for containers, got no healthcheck service for zaqar

Version-Release number of selected component (if applicable):
puppet-zaqar-14.3.0-0.20190313091807.aed1d72.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy undercloud 
2. Check the list of containers: sudo podman ps
3. Run healthcheck for zaqar container:
[stack@undercloud-0 ~]$ systemctl status tripleo_zaqar_healthcheck.service

Actual results:
Unit tripleo_zaqar_healthcheck.service could not be found.

Expected results:
Healthcheck returns 0/SUCCESS

Additional info: