Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1689692

Summary: First (top) icon in GNOME Activities disappears even though a favourite
Product: [Fedora] Fedora Reporter: Phil Wyett <philwyett>
Component: gnome-shellAssignee: Owen Taylor <otaylor>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: 0xalen, anto.trande, fmuellner, gecko-bugs-nobody, gnome-sig, jadahl, jhorak, john.j5live, kengert, otaylor, pjasicek, rhughes, rstrode, sandmann
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-21 01:49:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screenshot of missing firefox icon - Should be at top of Activities
none
Screenshot to show that placeholder is in place and hint appears none

Description Phil Wyett 2019-03-17 19:53:02 UTC
Created attachment 1545029 [details]
Screenshot of missing firefox icon - Should be at top of Activities

Description of problem:

Firefox icon disappears from GNOME Activities even though a favourite.

How reproducible:

Most of the time.

Steps to Reproduce:
1. Install fedora 30 branched.
2. Log into GNOME desktop.
3. Wait some time or use the desktop.

Actual results:

At certain times the firefox icon will disappear.

Expected results:

Icon of a favourite application should appear.

Additional info:

See screenshot.

Fedora 30 branched using default GNOME/Wayland installed as a QEMU/KVM VM on RHEL 7.x.

Comment 1 Phil Wyett 2019-03-17 20:12:38 UTC
Also occurs using GNOME on Xorg.

Comment 2 Phil Wyett 2019-03-18 15:33:42 UTC
Update description and swap to gnome-shell component.

If you move say the files icon or other to the top, it will disappear.

Comment 3 Phil Wyett 2019-03-18 15:34:58 UTC
Created attachment 1545365 [details]
Screenshot to show that placeholder is in place and hint appears

Comment 4 Phil Wyett 2019-03-21 01:49:55 UTC

*** This bug has been marked as a duplicate of bug 1690429 ***