Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 168872

Summary: Incomplete services (again)
Product: [Fedora] Fedora Reporter: Bill Nottingham <notting>
Component: setupAssignee: Phil Knirsch <pknirsch>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: andy, nalin, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-01-31 13:06:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1907    
Bug Blocks: 150221    

Description Bill Nottingham 2005-09-20 19:49:50 UTC
+++ This bug was initially created as a clone of Bug #1907 +++

The files /etc/services and /etc/protocols are rather
incomplete. Why not use the originally published by IANA?

-- Additional comment from pbrown@redhat.com on 1999-03-31 17:44 EST --
setup-1.9.2-2 and later contain complete /etc/services and
/etc/protocols files.

-- Additional comment from pcfe@redhat.com on 2002-07-08 19:17 EST --
We have since this was fixed in 1999 become out of sync with the official list
again.

Could we please have another update or even better have it generated
automatically from <http://www.iana.org/assignments/port-numbers> when the rpm
is built?

Having an up to date services file makes parsing firewall log files so much easier.

-- Additional comment from jturner@redhat.com on 2003-09-09 09:54 EST --
We again have discrepancies with setup-2.5.27-1.1.

-- Additional comment from notting@redhat.com on 2004-05-04 23:29 EST --
Cleaned up in 2.5.32-1.

-- Additional comment from notting@redhat.com on 2004-05-04 23:41 EST --
Deferred from 2.5.32-1

-- Additional comment from notting@redhat.com on 2004-09-23 01:33 EST --
*** Bug 82104 has been marked as a duplicate of this bug. ***

-- Additional comment from symbiont@berlios.de on 2005-04-12 05:08 EST --
Lot's of updates from November 2004, please ensure a new services file is in  
place for FC4.  Service that I'm looking for in particular is OpenVPN on 1194.  

-- Additional comment from notting@redhat.com on 2005-09-20 15:30 EST --
This problem is scheduled to be resolved in a future major release of Red Hat
Enterprise Linux. Red Hat does not currently plan to provide a resolution for
this in a Red Hat Enterprise Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects.

Comment 1 Phil Knirsch 2006-01-24 19:50:57 UTC
I've created and hugely updated /etc/services which contains almost all know
officiall services from IANA.

It can be found here:

http://people.redhat.com/pknirsch/services

Please give it a try and tell me if it works properly now.

Thanks,

Read ya, Phil

Comment 2 Phil Knirsch 2006-01-31 13:06:40 UTC
Putting new /etc/services in rawhide setup package today.

Closing as fixed in RAWHIDE.

Read ya, Phil