Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1686983

Summary: drop ppc64 and ppc64le from mono_arches for F30
Product: [Fedora] Fedora Reporter: Timotheus Pokorra <mailinglists>
Component: redhat-rpm-configAssignee: Florian Festi <ffesti>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: ajax, belegdol, carl, ffesti, fweimer, i.gnatenko.brain, john.j5live, jonathan, pmatilai, praiskup, tibbs
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-03 04:21:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1588734    

Description Timotheus Pokorra 2019-03-08 19:49:28 UTC
We have bug 1588734 for Mono 4.8, which does not build on ppc64 and ppc64le anymore. We were not able to resolve this.
And with Mono 5 around the corner (bug 1436896), we hopefully will have Mono 5 in Rawhide soon, which should compile for ppc64 just fine.

The suggestion is now to drop ppc64 and ppc64le from the macro mono_arches, so that all the packages in F30 depending on Mono can be built without adjustments.

Comment 1 Jason Tibbitts 2019-03-08 20:06:02 UTC
Note that PPC64 was dropped from Fedora as an architecture with F30, not that it really matters here.

Note tha %mono_arches currently contains:
  %{ix86} x86_64 sparc sparcv9 ia64 %{arm} aarch64 alpha s390x ppc ppc64 ppc64le

How much of that is actually correct (or even tested)?

Comment 2 Timotheus Pokorra 2019-03-08 20:57:23 UTC
I know it works for x86_64 armv7hl i686 s390x aarch64 because the latest build worked on those architectures: https://koji.fedoraproject.org/koji/buildinfo?buildID=1207550

I cannot speak for the other architectures.

Comment 3 Panu Matilainen 2019-03-12 11:35:45 UTC
sparc, alpha, ia64... rrrrrriiight :)

Comment 4 Carl George 2019-03-26 20:47:41 UTC
This is still broken in ppc64le rawhide and f30.  mono-4.8.0-17.fc30 is live in f30 and f31 buildroots, without ppc64le packages, but ppc64le is still listed in %mono_arches.

Comment 5 Timotheus Pokorra 2019-03-27 05:04:19 UTC
We are working on getting Mono 5 into F30, which builds fine on ppc64le. We have a deadline till Sunday night: https://pagure.io/fesco/issue/2105#comment-562570

Only issue is now s390x: bug 1692646

Comment 6 Timotheus Pokorra 2019-04-03 04:21:58 UTC
Closing this issue because Mono builds fine on ppc64le in F30 and rawhide again.