Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 168654

Summary: SCIM causes gnome-ssh-askpass to fail closing
Product: [Fedora] Fedora Reporter: Warren Togami <wtogami>
Component: scimAssignee: Jens Petersen <petersen>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: eng-i18n-bugs, tmraz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-12-20 19:38:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150221    

Description Warren Togami 2005-09-19 04:02:46 UTC
GNOME login is stuck after ssh-askpass because gnome-ssh-askpass process becomes
defunct.  This seems to be the same behavior as Bug #132340 where IIIMF broke
gnome-ssh-askpass.  This behavior began after the immodule language list removal
of Bug #167088.

Produce Procedure:
[warren@ibmlaptop ~]$ cat .Xclients-default
ssh-add < /dev/null
exec gnome-session

Comment 1 Jens Petersen 2005-09-22 01:43:33 UTC
Can you explain in more detail how to reproduce this?

Comment 2 Warren Togami 2005-09-22 19:21:16 UTC
1) Have a ssh key with passphrase
2) Create ~/.Xclients-default containing the above two lines.
3) Login to GNOME session using en_US.UTF-8
4) See it get stuck before displaying gnome-ssh-askpass.

Comment 3 Warren Togami 2005-09-23 04:29:00 UTC
Hmm after the latest FC5 upgrade this problem went away.  Closing NOTABUG for
now, will reopen if I see it again.

Comment 4 Warren Togami 2005-09-23 15:20:44 UTC
I was wrong, it happens after I enter the ssh passphrase.  The dialog disappears
and it is stuck there forever with gnome-ssh-askpass defunct.  I need to kill
ssh-add for it to begin to run GNOME.


Comment 5 Warren Togami 2005-12-20 19:38:38 UTC
A more recent version of SCIM no longer enables IM in GTK+ password dialogs, so
there are now two things preventing this from happening in gnome-ssh-askpass.  I
suppose this is only a symptom of the debug prints going to stdout combined with
the crap redirection used by askpass.  Hopefully nothing else is affected by
this.  So closing...