Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1662

Summary: pcmcia network card and dhcp (dependencies of scripts)
Product: [Retired] Red Hat Linux Reporter: Marc MERLIN <marc_soft>
Component: initscriptsAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-22 15:52:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Marc MERLIN 1999-03-22 04:49:19 UTC
The network script tries to do a dhcp request before the
pcmcia subsystem is configured. It fails after waiting for 5
sec or so, pcmcia is brought up, dhcp is done again and
succeeds.

Another problem is that routed is run before pcmcia is
brought up, so once the network comes up, it complains about
getting packets from unknown routers.
If routed is run after the network is brought up, it knows
what subnet it's on, and dowsn't complain about getting
updates from subnet routers.

To me, it looks like if pcmcia was brought up before
networking, it would solve both problems (and other ones,
like for instance ppp that dials automatically on a pcmcia
modem when networking is brought up).

Comment 1 Bill Nottingham 1999-03-22 15:52:59 UTC
this should be fixed in 5.9; card services will be loaded
as soon as any pcmcia modules are requested.

You might try updating to the modutils in Starbuck/Rawhide
(recompile the SRPMS, the binaries are based on glibc2.1),
and adding the following line to your /etc/conf.modules:

pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start