Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1650017

Summary: glustereventsd ImportError: attempted relative import with no known parent package
Product: [Community] GlusterFS Reporter: mathieu.gallissot
Component: eventsapiAssignee: bugs <bugs>
Status: NEW --- QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5CC: amukherj, avishwan, bugs, bugzilla, pasik
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description mathieu.gallissot 2018-11-15 06:42:09 UTC
Description of problem:

After a fresh installation of gluster from the official repository, I'm anable to peer any probes. Checking the services, I have an error while starting glustereventsd using systemd with the following trace

nov. 15 07:31:12 hel glustereventsd[2832]: Traceback (most recent call last):
nov. 15 07:31:12 hel glustereventsd[2832]:   File "/usr/sbin/glustereventsd", line 24, in <module>
nov. 15 07:31:12 hel glustereventsd[2832]:     import handlers
nov. 15 07:31:12 hel glustereventsd[2832]:   File "/usr/lib/x86_64-linux-gnu/glusterfs/events/handlers.py", line 12, in <module>
nov. 15 07:31:12 hel glustereventsd[2832]:     import utils
nov. 15 07:31:12 hel glustereventsd[2832]:   File "/usr/lib/x86_64-linux-gnu/glusterfs/events/utils.py", line 29, in <module>
nov. 15 07:31:12 hel glustereventsd[2832]:     from .eventsapiconf import (LOG_FILE,
nov. 15 07:31:12 hel glustereventsd[2832]: ImportError: attempted relative import with no known parent package

Version-Release number of selected component (if applicable):
glusterd --version
glusterfs 5.0

Comment 1 Mrten 2018-12-04 17:10:54 UTC
same with 5.1, ubuntu package here

Comment 2 Mrten 2018-12-04 17:26:06 UTC
see bug 1649054 for patch

Comment 3 Aravinda VK 2019-02-21 06:25:48 UTC
Sent Patch upstream: https://review.gluster.org/#/c/glusterfs/+/22247