Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163960

Summary: cups classes failover doesn't work
Product: Red Hat Enterprise Linux 3 Reporter: Bastien Nocera <bnocera>
Component: cupsAssignee: Tim Waugh <twaugh>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: k.georgiou, tao
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: RHBA-2007-0475 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-11 18:37:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 234011    

Description Bastien Nocera 2005-07-22 13:45:36 UTC
After configuring two printer as a class, schedule 10 printjobs one page each.

1-2 minutes before printing pull the plug on say printer 2.

Start printing 1st job get sent to printer 1 and print second job gets sent to
printer 2 which is not there

It doesn't print as printer 2 isn't plugged in and sits there waiting. All the
remaining jobs getting sent to printer 1.

The problem is acknowledged upstream:
http://www.cups.org/str.php?L1084

Comment 1 Tim Waugh 2005-07-22 13:53:28 UTC
Judging from the upstream reaction, I guess Red Hat Enterprise Linux 4 is
affected too.

Comment 9 Red Hat Bugzilla 2007-06-11 18:37:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0475.html