Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163857

Summary: Using liblvm2clusterlock.so generates broken initrd images (kernel panic)
Product: [Retired] Red Hat Cluster Suite Reporter: Axel Thimm <axel.thimm>
Component: lvm2-clusterAssignee: Christine Caulfield <ccaulfie>
Status: CLOSED NOTABUG QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: agk
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-22 13:18:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Axel Thimm 2005-07-21 16:44:35 UTC
Description of problem:
or making use of clvmd one needs to change lvm.conf to include

    locking_type = 2
    locking_library = "/usr/lib64/liblvm2clusterlock.so"

kernels installed later will mkinitrd with this config file which will make the
kernel panic.

Version-Release number of selected component (if applicable):
2.01.09-5.0.RHEL4

How reproducible:
always

Steps to Reproduce:
1.See above
2.
3.
  
Actual results:
kernel panic on reboot

Expected results:


Additional info:
lvm in initrd is statically linked but the cluster locking mechanisms are
dynamically loaded even so. The initrd should contain a different version of
lvm.conf than the filesystem.

Comment 1 Axel Thimm 2005-07-22 13:18:03 UTC
The initrd was broken due to bad udev/qla2300 interaction, sorry for the noise ...