Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163632

Summary: Running artsdsp crashes my system
Product: [Fedora] Fedora Reporter: Glen <glen>
Component: artsAssignee: Ngo Than <than>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 4CC: jonrysh
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-19 18:42:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Glen 2005-07-19 17:35:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I was having trouble with skype, so I tried running it like so:
artsdsp skype

This subsequently locked up my system.

The version of skype I'm running is 1.1.0.20.  And it actually says it's built for Fedora Core 3, but seems to work ok, aside from sound being kinda messed up.

I haven't tried to reproduce the lockup yet, but I will when I get a chance.

Version-Release number of selected component (if applicable):
arts-1.4.1-0.fc4.1

How reproducible:
Didn't try


Additional info:

Comment 1 Ngo Than 2005-07-19 18:42:56 UTC
I'm not able to reproduce this problem on my working machine and notebook.
Please reopen it again if you have a testcase, which causes this problem. Thanks

Comment 2 Jonathan Ryshpan 2005-12-11 21:15:31 UTC
This may be similar to the following:

Sometimes artsd locks up, generally when a program using it crashes of locks up.
 When this happens, the panel locks up too, making KDE pretty hard to use. 
Artsshell won't start, so it provides no control or info, but if artsd is
terminated by "pkill -9 artsd", the panel recovers and something respawns artsd.

I can often make artsd lock up in this wasy by running realplay, which seems to
accept input infrequently (maybe about every 10 seconds).  I start realplay and
then stop by clicking the "X" on the window decoration.  Pretty often, realplay
doesn't respond in time to prevent the "Window not responding" message from KDE.
 I then ask realplay to be terminated forcefully.  And sometimes, this locks up
artsd.

Comment 3 Jonathan Ryshpan 2005-12-11 21:28:43 UTC
In my last comment, the first sentence should read:

Sometimes artsd locks up, generally when a program using it crashes OR
locks up.

Sorry for the typo.