Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163571

Summary: /dev/raw1394 : no such file
Product: [Fedora] Fedora Reporter: Paulos Siahu <psiahu>
Component: dvgrabAssignee: Warren Togami <wtogami>
Status: CLOSED CANTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: kna, schiavo.michele
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-17 17:26:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 150221    

Description Paulos Siahu 2005-07-19 00:17:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
dvgrab expects raw1394 to be in /dev/raw1394 but the raw1394 module (as loaded by modprobe, etc) creates the device in /dev/raw/raw1394

Also, dvgrab capture stops after a few seconds.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. modprobe raw1394
2. dvgrab capturefile
3. ln -s /dev/raw/raw1394 /dev/raw1394
4. chmod 666 /dev/raw/raw1394
5. dvgrab capturefile
  

Actual Results:  After step 2: Error - /dev/raw1394 no such file
Worked around by steps 3 and 4

After step 5: Error - 
0.00 MB 0 frames
Capture Stopped
Error: no DV

Expected Results:  Expected dvgrab to start capturing the dv input and writing output avi file(s).

Additional info:

Comment 1 Knut-Håvard Aksnes 2005-08-03 06:28:03 UTC
More or less the same workaround worked for me. With the following differences.
1) I didn't do the chmod, i did run dvgrab as root instead
2) I did use the --timestamp and --autosplit options on dvgrab

Have you tried to start the camera after doing the modprobe?
This could be needed to make the driver know about the camera.

Comment 2 Paulos Siahu 2005-08-04 01:58:37 UTC
The main issue here is that dvgrab expects the device to be in /dev/raw1394 but 
Fedora actually creates the device in /dev/raw/raw1394. It appears to me that 
the dvgrab developer hadn't been informed of the location change. The solution 
that I can envisage is either requesting the dvgrab developer to also search 
the new raw1394 location or for the module loader (modprobe?) to automatically 
create a symlink as the old location. I think this is a bug that needs to be 
resolved in the next release because not many ordinary users would realise the 
workaround.

The second issue with stopped capture was caused by an ide dma interrupt due to 
my bad harddisk. I resolved it by turning off the dma support.


Comment 3 Walter Justen 2005-08-25 09:57:56 UTC
*** Bug 133798 has been marked as a duplicate of this bug. ***

Comment 4 Warren Togami 2005-08-26 02:02:53 UTC
Can someone please talk to upstream about this?  We could add a hack to our
package, but it is preferable that we use upstream's solution.

Comment 5 Knut-Håvard Aksnes 2005-08-26 07:40:10 UTC
The bug has been reported in the bug reporting system for dvgrab. I have left a
link to this bug report on their site the bug report can be reached at
http://jira.schirmacher.de/jira-kino/browse/DVGRAB-48