Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163498

Summary: smartd reports failed self-test only once
Product: Red Hat Enterprise Linux 3 Reporter: Milan Kerslager <milan.kerslager>
Component: kernel-utilsAssignee: Tomas Mraz <tmraz>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-23 09:08:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Milan Kerslager 2005-07-18 12:10:54 UTC
I'm running short and long test periodically from the cron job. The smard daemon
is running and reports failed test only once. This is a bug as every error
should be reported IMHO.

In the /etc/smartd.conf I have only one line:
DEVICESCAN -H -m root

Even I have in /var/log/messages lines like below, no mail is sended to the
administrator (only the first).

smartd[1698]: Device: /dev/hdb, FAILED SMART self-check. BACK UP DATA NOW!

Comment 1 Milan Kerslager 2005-10-09 21:49:56 UTC
After U6 release, nothing has changed as kernel-utils are the same
(2.4-8.37.12). I expect this is a serious bug to not announce repeated HDD failures.

Comment 2 Tomas Mraz 2005-11-23 09:08:01 UTC
This is intended behaviour.

See 'man smartd' -M option how to modify it.