Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163399

Summary: aspell conflicts with info package
Product: [Fedora] Fedora Reporter: Robert Scheck <redhat-bugzilla>
Component: aspellAssignee: Ivana Varekova <varekova>
Status: CLOSED CURRENTRELEASE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-18 07:17:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robert Scheck 2005-07-15 20:33:16 UTC
Description of problem:
aspell conflicts at installing with stuff of the info package.

Version-Release number of selected component (if applicable):
aspell-0.60.3-1

How reproducible / Steps to Reproduce:
Everytime, try to install aspell aspell-0.60.3-1 from Rawhide.

Actual results:
The following works for me and solves the problem:

--- snipp ---
--- aspell.spec         2005-07-13 16:51:39.000000000 +0200
+++ aspell.spec.rsc     2005-07-15 22:18:01.000000000 +0200
@@ -58,14 +58,19 @@

 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
+rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir

-#rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
+%post
+/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
+/sbin/ldconfig
+
+%preun
+if [ $1 = 0 ]; then
+    /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
+fi

-#mv $RPM_BUILD_ROOT/usr/share/doc/aspell $RPM_BUILD_ROOT/usr/share/doc/aspell-%
{version}
-
-
-%post -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
+
 %clean
 rm -rf $RPM_BUILD_ROOT

--- snapp ---

Expected results:
Fix containing the stuff as above or even better ;-)

Comment 1 Ivana Varekova 2005-07-18 07:17:40 UTC
Thank you for your notice.
This bug is fixed in the laat version - aspell-0.60.3-2.i386.rpm.