Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163269

Summary: [IM]The composition mode gets lost when focus traverses
Product: Red Hat Enterprise Linux 3 Reporter: Xiaobin Lu <xiaobinlu02>
Component: openoffice.orgAssignee: Caolan McNamara <caolanm>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: benl, eng-i18n-bugs
Target Milestone: ---Keywords: i18n
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: RHEL3U7NAK
Fixed In Version: 1.9.121-3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-04-12 07:59:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Xiaobin Lu 2005-07-14 17:39:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
For any application, for example, Openoffice.org Calc, if you enable japanese input in one text field and move the focus to another text field, you need to enable japanese input again in order to input Japanese. This bug won't be seen in Advanced server 2.1.

Version-Release number of selected component (if applicable):
kinput2-canna-wnn6-v3.1-12.EL

How reproducible:
Always

Steps to Reproduce:
1. Open Openoffice.org Calc
2. Focus the keyboard input on the top textfield and enable japanese input, type "ka", you will see it gets converted to japanese character, press enter. 
3. Move the focus to another text field, type "ka", you will see the English "ka" character 
  

Actual Results:  Actual "ka" is displayed

Expected Results:  You should see "ka" converted to japanese character

Additional info:

Not reproducible with Chinese, Korean input method. Not reproducible with Advanced Server 2.1

Comment 1 Akira TAGOH 2005-07-19 02:33:03 UTC
This is not a kinput2 bug because it's technically caused by OOo has the
different Input Context for each cells. kinput2, erm, Input Method which
supports the multiple Input Contexts basically can has different behaviors every
Input Contexts. It's the applications choice.

Comment 2 Caolan McNamara 2005-07-19 08:30:16 UTC
somewhat related to bug 158921

Comment 3 Caolan McNamara 2005-07-28 15:28:07 UTC
seems good in 1.9.121-3 rawhide.

caolanm->akira can you confirm this is now desired behaviour ?

Comment 4 Akira TAGOH 2005-07-29 04:47:42 UTC
Yes, it looks good. however sorry, this is an RHEL3 bug. reopening.

Comment 6 Caolan McNamara 2005-08-16 08:31:22 UTC
Adding to proposed list, though likely relatively large impact and somewhat
risky IMO for 1.1.X codebase.

Comment 12 Caolan McNamara 2006-04-12 07:59:45 UTC
No issuetracker score, no IM updates planned. Decision has been made to move
such IM bugs to RHEL-5 nextrelease (OOo 2.0.X series)