Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163182

Summary: Network tests fail due to nfs mount timeout
Product: [Retired] Red Hat Ready Certification Tests Reporter: Matt Chorman <matthew.t.chorman>
Component: rhr2-testsAssignee: Rob Landry <rlandry>
Status: CLOSED CURRENTRELEASE QA Contact: Rob Landry <rlandry>
Severity: medium Docs Contact:
Priority: medium    
Version: 2CC: richardl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 1.1.3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-27 17:18:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matt Chorman 2005-07-13 19:44:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Running the network tests fails on the UDP test component with the following error:

Mount: RPC: Timed out

This occurs because the mount command is executed immediately after running the exportfs command. 

In /usr/share/rhr/tests/network/udp on line 23 I added a "sleep 30" command. This causes the test to pass.

Version-Release number of selected component (if applicable):
rhr2-rhel4-1.0-14a.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Run iSpec on test server.
2. Install RHEL4 UP1 on System Under Test using network boot and kickstart file provided by iSpec.
3. Allow system to run through automated tests. Network tests will fail with above error message.
  

Additional info:

Comment 1 Matt Chorman 2005-07-27 17:18:34 UTC
Sorry, did not realize this package was outdate. Running with
rhr2-1.1.3.noarch.rpm allows this test to pass.

I am closing this bug and recommend you not spend any time running this down as
an update package works.